CVE-2017-18917 Mattermost Server uses weak hashing for OAuth, email verification tokens and invitations

High 7.5 Published Updated

Weak hashing in Mattermost Server allows attackers to bypass security controls or take over accounts via compromised invitation and verification tokens.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-18917?

CVE-2017-18917 is a high-severity vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. Weak hashing was used for e-mail invitations, OAuth, and e-mail verification tokens.

Weakness: CWE-916

Which versions are affected by CVE-2017-18917?

5 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoAll versions3.7.5-0.20170421192444-247cd1e51a8c
github.com/mattermost/mattermost-server GoAll versions3.7.5-0.20170421192444-247cd1e51a8c
github.com/mattermost/mattermost-server GoFrom 3.8.03.8.2
github.com/mattermost/mattermost-server GoFrom 3.8.03.8.2
github.com/mattermost/mattermost-server GoFrom 3.8.0+incompatible3.8.2+incompatible

Products include Mattermost Mattermost Server.

How do I fix CVE-2017-18917?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 3.7.5-0.20170421192444-247cd1e51a8c, 3.8.2 or 3.8.2+incompatible.

Is CVE-2017-18917 being exploited?

There is no known exploitation of CVE-2017-18917 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-jxc4-w54c-qv5r, GO-2026-4463.

Is CVE-2017-18917 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free