CVE-2017-20017 The Next Generation of Genealogy Sitebuilding timeline2.php sql injection

Medium 6.3 Published Updated

Remote attackers can exploit SQL injection in timeline2.php to read or modify database contents in The Next Generation of Genealogy Sitebuilding.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2017-20017?

CVE-2017-20017 is a medium-severity SQL injection vulnerability in unspecified The Next Generation of Genealogy Sitebuilding, published on 5 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability, which was classified as critical, has been found in The Next Generation of Genealogy Sitebuilding up to 11.1.0. This issue affects some unknown processing of the file /timeline2.php. The manipulation of the argument primaryID leads to sql injection. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 11.1.1 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-89

Which versions are affected by CVE-2017-20017?

It affects 1 product.

Products include Tngsitebuilding the Next Generation of Genealogy Sitebuilding.

How do I fix CVE-2017-20017?

No fix has been published for CVE-2017-20017 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2017-20017 being exploited?

There is no known exploitation of CVE-2017-20017 in the wild and no public exploit code.

Sources

Also known as GHSA-89v6-4839-2jwg.

Is CVE-2017-20017 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free