{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20017 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2017-20017 yet. Limit exposure of the affected software until one is available.","what":"CVE-2017-20017 is a medium-severity SQL injection vulnerability in unspecified The Next Generation of Genealogy Sitebuilding, published on 5 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-20017 and fix it if it is affected.\n\nWhat it is: CVE-2017-20017 is a medium-severity SQL injection vulnerability in unspecified The Next Generation of Genealogy Sitebuilding, published on 5 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-20017 in the wild and no public exploit code.\n\nAffected product: unspecified The Next Generation of Genealogy Sitebuilding. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20017/ (Markdown: https://insights.sbomify.com/CVE-2017-20017/index.md)","id":"CVE-2017-20017","markdown":"https://insights.sbomify.com/CVE-2017-20017/index.md","name":"CVE-2017-20017","record":{"aliases":["GHSA-89v6-4839-2jwg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Genealogy sitebuilding software","requires_auth":"low_privilege","summary":"Remote attackers can exploit SQL injection in timeline2.php to read or modify database contents in The Next Generation of Genealogy Sitebuilding.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"the_next_generation_of_genealogy_sitebuilding","vendor":"tngsitebuilding"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"A vulnerability, which was classified as critical, has been found in The Next Generation of Genealogy Sitebuilding up to 11.1.0. This issue affects some unknown processing of the file /timeline2.php. The manipulation of the argument primaryID leads to sql injection. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 11.1.1 is able to address this issue. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"The Next Generation of Genealogy Sitebuilding timeline2.php sql injection","id":"CVE-2017-20017","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"sql_injection","year":"2017"},"n_packages":0,"n_references":1,"next":{"headline":"XAMPP Installer uncontrolled search path","id":"CVE-2017-20018"},"packages":[],"prev":{"headline":"WEKA INTEREST Security Scanner Portscan memory allocation","id":"CVE-2017-20016"},"products":["The Next Generation of Genealogy Sitebuilding"],"published":"2022-06-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["unspecified"]},"summary":"Remote attackers can exploit SQL injection in timeline2.php to read or modify database contents in The Next Generation of Genealogy Sitebuilding.","url":"https://insights.sbomify.com/CVE-2017-20017/"}