# CVE-2017-20017: The Next Generation of Genealogy Sitebuilding timeline2.php sql injection

> Remote attackers can exploit SQL injection in timeline2.php to read or modify database contents in The Next Generation of Genealogy Sitebuilding.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Jun 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-89v6-4839-2jwg

## What is CVE-2017-20017?

CVE-2017-20017 is a medium-severity SQL injection vulnerability in unspecified The Next Generation of Genealogy Sitebuilding, published on 5 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability, which was classified as critical, has been found in The Next Generation of Genealogy Sitebuilding up to 11.1.0. This issue affects some unknown processing of the file /timeline2.php. The manipulation of the argument primaryID leads to sql injection. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 11.1.1 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2017-20017?

It affects 1 product.


Products: Tngsitebuilding the Next Generation of Genealogy Sitebuilding.

## How do I fix CVE-2017-20017?

No fix has been published for CVE-2017-20017 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-20017 being exploited?

There is no known exploitation of CVE-2017-20017 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-20017 and fix it if it is affected.

What it is: CVE-2017-20017 is a medium-severity SQL injection vulnerability in unspecified The Next Generation of Genealogy Sitebuilding, published on 5 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-20017 in the wild and no public exploit code.

Affected product: unspecified The Next Generation of Genealogy Sitebuilding. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-20017/ (Markdown: https://insights.sbomify.com/CVE-2017-20017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-20017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-20017
- OSV: https://osv.dev/vulnerability/CVE-2017-20017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-20017/
Summaries are generated and may contain mistakes; the official description above is the record.
