{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20027 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2017-20027 yet. Limit exposure of the affected software until one is available.","what":"CVE-2017-20027 is a medium-severity cross-site scripting vulnerability in unspecified HumHub, published on 9 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-20027 and fix it if it is affected.\n\nWhat it is: CVE-2017-20027 is a medium-severity cross-site scripting vulnerability in unspecified HumHub, published on 9 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-20027 in the wild and no public exploit code.\n\nAffected product: unspecified HumHub. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20027/ (Markdown: https://insights.sbomify.com/CVE-2017-20027/index.md)","id":"CVE-2017-20027","markdown":"https://insights.sbomify.com/CVE-2017-20027/index.md","name":"CVE-2017-20027","record":{"aliases":["GHSA-7pxw-jp74-vp3g"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"HumHub social platform","requires_auth":"none","summary":"Remote attackers can execute arbitrary scripts in user browsers via DOM-based cross-site scripting in HumHub, potentially leading to session hijacking.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"humhub","vendor":"humhub"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"}],"description":"A vulnerability was found in HumHub up to 1.0.1 and classified as problematic. Affected by this issue is some unknown functionality. The manipulation leads to cross site scripting (DOM). The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.1 is able to address this issue. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"HumHub DOM cross site scriting","id":"CVE-2017-20027","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2017"},"n_packages":0,"n_references":2,"next":{"headline":"HumHub privileges management","id":"CVE-2017-20028"},"packages":[],"prev":{"headline":"HumHub Reflected cross site scriting","id":"CVE-2017-20026"},"products":["HumHub"],"published":"2022-06-09","related":[{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2014-9528","kev_date_added":null,"published":"2015-01-06"},{"cvss_score":7.1,"headline":"HumHub is vulnerable to XSS through its Meta Search component","id":"CVE-2025-64442","kev_date_added":null,"published":"2025-11-07"},{"cvss_score":6.9,"headline":"HumHub: XSS in Button component","id":"CVE-2026-29048","kev_date_added":null,"published":"2026-03-06"},{"cvss_score":6.9,"headline":"User enumeration in HubHub","id":"CVE-2024-52043","kev_date_added":null,"published":"2024-11-06"},{"cvss_score":6.5,"headline":"Improper access control in humhub","id":"CVE-2022-24865","kev_date_added":null,"published":"2022-04-20"},{"cvss_score":6.5,"headline":"Authorization Bypass in Space Invite in HumHub","id":"CVE-2021-43847","kev_date_added":null,"published":"2021-12-20"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2019-11564","kev_date_added":null,"published":"2019-05-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["unspecified"]},"summary":"Remote attackers can execute arbitrary scripts in user browsers via DOM-based cross-site scripting in HumHub, potentially leading to session hijacking.","url":"https://insights.sbomify.com/CVE-2017-20027/"}