CVE-2017-20057 Elefant CMS Persistent cross site scriting

Medium 4.3 Published Updated

Attackers can inject persistent scripts via the username field in Elefant CMS, potentially leading to session hijacking or malicious actions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-20057?

CVE-2017-20057 is a medium-severity cross-site scripting vulnerability in Elefant CMS, published on 20 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A vulnerability classified as problematic has been found in Elefant CMS 1.3.12-RC. Affected is an unknown function. The manipulation of the argument username leads to basic cross site scripting (Persistent). It is possible to launch the attack remotely. Upgrading to version 1.3.13 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-79, CWE-80

Which versions are affected by CVE-2017-20057?

2 open source packages ship an affected version, including elefant/cms. It affects 1 product.

PackageAffectedFixed in
elefant/cms PackagistAll versions1.3.13
elefant/cms PackagistAll versions1.3.13

Products include Elefantcms Elefant Cms.

How do I fix CVE-2017-20057?

Upgrade elefant/cms to 1.3.13 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-20057 being exploited?

There is no known exploitation of CVE-2017-20057 in the wild and no public exploit code.

Sources

Also known as GHSA-xwj7-29j7-rw76.

Is CVE-2017-20057 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free