CVE-2017-20058 Elefant CMS Version Comparison Persistent cross site scriting

Medium 4.3 Published Updated

Persistent cross-site scripting in Elefant CMS allows remote attackers to inject malicious scripts, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-20058?

CVE-2017-20058 is a medium-severity cross-site scripting vulnerability in Elefant CMS, published on 20 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A vulnerability classified as problematic was found in Elefant CMS 1.3.12-RC. Affected by this vulnerability is an unknown functionality of the component Version Comparison. The manipulation leads to basic cross site scripting (Persistent). The attack can be launched remotely. Upgrading to version 1.3.13 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-79, CWE-80

Which versions are affected by CVE-2017-20058?

2 open source packages ship an affected version, including elefant/cms. It affects 1 product.

PackageAffectedFixed in
elefant/cms PackagistAll versions1.3.13
elefant/cms PackagistAll versions1.3.13

Products include Elefantcms Elefantcms.

How do I fix CVE-2017-20058?

Upgrade elefant/cms to 1.3.13 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-20058 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-20058 exists.

Sources

Also known as GHSA-5hfm-g799-wjw6.

Is CVE-2017-20058 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free