{"answers":{"affected":"2 open source packages ship an affected version, including elefant/cms. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-20058 exists.","fix":"Upgrade elefant/cms to 1.3.13 or later.","what":"CVE-2017-20058 is a medium-severity cross-site scripting vulnerability in Elefant CMS, published on 20 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-20058 and fix it if it is affected.\n\nWhat it is: CVE-2017-20058 is a medium-severity cross-site scripting vulnerability in Elefant CMS, published on 20 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-20058 exists.\n\nAffected packages and fixed versions:\n- elefant/cms (Packagist): affected all versions; fixed in 1.3.13\n- elefant/cms (Packagist): affected all versions; fixed in 1.3.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20058/ (Markdown: https://insights.sbomify.com/CVE-2017-20058/index.md)","id":"CVE-2017-20058","markdown":"https://insights.sbomify.com/CVE-2017-20058/index.md","name":"CVE-2017-20058","record":{"aliases":["GHSA-5hfm-g799-wjw6"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Elefant CMS","requires_auth":"none","summary":"Persistent cross-site scripting in Elefant CMS allows remote attackers to inject malicious scripts, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"elefantcms","vendor":"elefantcms"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"}],"description":"A vulnerability classified as problematic was found in Elefant CMS 1.3.12-RC. Affected by this vulnerability is an unknown functionality of the component Version Comparison. The manipulation leads to basic cross site scripting (Persistent). The attack can be launched remotely. Upgrading to version 1.3.13 is able to address this issue. It is recommended to upgrade the affected component.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Elefant CMS Version Comparison Persistent cross site scriting","id":"CVE-2017-20058","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Elefant CMS Title Persistent cross site scriting","id":"CVE-2017-20059"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.13"],"introduced":["0"],"last_affected":[],"package":"elefant/cms","purl":null,"source":"GHSA-5hfm-g799-wjw6"},{"ecosystem":"Packagist","fixed":["1.3.13"],"introduced":["0"],"last_affected":[],"package":"elefant/cms","purl":"pkg:composer/elefant/cms","source":"GHSA-5hfm-g799-wjw6"}],"prev":{"headline":"Elefant CMS Persistent cross site scriting","id":"CVE-2017-20057"},"products":["CMS"],"published":"2022-06-20","related":[{"cvss_score":9.8,"headline":"Elefant CMS Improper Input Validation","id":"CVE-2018-15601","kev_date_added":null,"published":"2018-08-21"},{"cvss_score":8.8,"headline":"Elefant CMS CSRF Vulnerability","id":"CVE-2018-16387","kev_date_added":null,"published":"2018-09-03"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2012-6521","kev_date_added":null,"published":"2013-01-24"},{"cvss_score":4.3,"headline":"Elefant CMS Multiple XSS Vulnerabilities","id":"CVE-2012-1296","kev_date_added":null,"published":"2012-08-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["Elefant"]},"summary":"Persistent cross-site scripting in Elefant CMS allows remote attackers to inject malicious scripts, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2017-20058/"}