CVE-2017-20060 Elefant CMS Blog Post Persistent cross site scriting

Low 3.5 Published Updated

Attackers can inject persistent scripts into blog posts, potentially stealing user sessions or executing malicious code in victim browsers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-20060?

CVE-2017-20060 is a low-severity cross-site scripting vulnerability in Elefant CMS, published on 20 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability, which was classified as problematic, was found in Elefant CMS 1.3.12-RC. This affects an unknown part of the component Blog Post Handler. The manipulation leads to basic cross site scripting (Persistent). It is possible to initiate the attack remotely. Upgrading to version 1.3.13 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-79, CWE-80

Which versions are affected by CVE-2017-20060?

2 open source packages ship an affected version, including elefant/cms. It affects 1 product.

PackageAffectedFixed in
elefant/cms PackagistAll versions1.3.13
elefant/cms PackagistAll versions1.3.13

Products include Elefantcms Elefant Cms.

How do I fix CVE-2017-20060?

Upgrade elefant/cms to 1.3.13 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-20060 being exploited?

There is no known exploitation of CVE-2017-20060 in the wild and no public exploit code.

Sources

Also known as GHSA-4453-g295-24mh.

Is CVE-2017-20060 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free