{"answers":{"affected":"2 open source packages ship an affected version, including elefant/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20060 in the wild and no public exploit code.","fix":"Upgrade elefant/cms to 1.3.13 or later.","what":"CVE-2017-20060 is a low-severity cross-site scripting vulnerability in Elefant CMS, published on 20 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-20060 and fix it if it is affected.\n\nWhat it is: CVE-2017-20060 is a low-severity cross-site scripting vulnerability in Elefant CMS, published on 20 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-20060 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- elefant/cms (Packagist): affected all versions; fixed in 1.3.13\n- elefant/cms (Packagist): affected all versions; fixed in 1.3.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20060/ (Markdown: https://insights.sbomify.com/CVE-2017-20060/index.md)","id":"CVE-2017-20060","markdown":"https://insights.sbomify.com/CVE-2017-20060/index.md","name":"CVE-2017-20060","record":{"aliases":["GHSA-4453-g295-24mh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Elefant CMS","requires_auth":"low_privilege","summary":"Attackers can inject persistent scripts into blog posts, potentially stealing user sessions or executing malicious code in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"elefant_cms","vendor":"elefantcms"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"}],"description":"A vulnerability, which was classified as problematic, was found in Elefant CMS 1.3.12-RC. This affects an unknown part of the component Blog Post Handler. The manipulation leads to basic cross site scripting (Persistent). It is possible to initiate the attack remotely. Upgrading to version 1.3.13 is able to address this issue. It is recommended to upgrade the affected component.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Elefant CMS Blog Post Persistent cross site scriting","id":"CVE-2017-20060","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Elefant CMS extended Reflected cross site scriting","id":"CVE-2017-20061"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.13"],"introduced":["0"],"last_affected":[],"package":"elefant/cms","purl":null,"source":"GHSA-4453-g295-24mh"},{"ecosystem":"Packagist","fixed":["1.3.13"],"introduced":["0"],"last_affected":[],"package":"elefant/cms","purl":"pkg:composer/elefant/cms","source":"GHSA-4453-g295-24mh"}],"prev":{"headline":"Elefant CMS Title Persistent cross site scriting","id":"CVE-2017-20059"},"products":["CMS"],"published":"2022-06-20","related":[{"cvss_score":6.3,"headline":"Elefant CMS File Upload drop privileges management","id":"CVE-2017-20063","kev_date_added":null,"published":"2022-06-20"},{"cvss_score":6.3,"headline":"Elefant CMS layout code injection","id":"CVE-2017-20064","kev_date_added":null,"published":"2022-06-20"},{"cvss_score":5,"headline":"Elefant CMS cross-site request forgery","id":"CVE-2017-20062","kev_date_added":null,"published":"2022-06-20"},{"cvss_score":4.3,"headline":"Elefant CMS Persistent cross site scriting","id":"CVE-2017-20057","kev_date_added":null,"published":"2022-06-20"},{"cvss_score":4.3,"headline":"Elefant CMS extended Reflected cross site scriting","id":"CVE-2017-20061","kev_date_added":null,"published":"2022-06-20"},{"cvss_score":3.5,"headline":"Elefant CMS Title Persistent cross site scriting","id":"CVE-2017-20059","kev_date_added":null,"published":"2022-06-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["Elefant"]},"summary":"Attackers can inject persistent scripts into blog posts, potentially stealing user sessions or executing malicious code in victim browsers.","url":"https://insights.sbomify.com/CVE-2017-20060/"}