CVE-2017-20061 Elefant CMS extended Reflected cross site scriting

Medium 4.3 Published Updated

Reflected cross-site scripting in Elefant CMS allows remote attackers to inject malicious scripts via the name argument in the admin extended page.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-20061?

CVE-2017-20061 is a medium-severity cross-site scripting vulnerability in Elefant CMS, published on 20 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability has been found in Elefant CMS 1.3.12-RC and classified as problematic. This vulnerability affects unknown code of the file /admin/extended. The manipulation of the argument name with the input %3Cimg%20src=no%20onerror=alert(1)%3E leads to basic cross site scripting (Reflected). The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.3.13 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-79, CWE-80

Which versions are affected by CVE-2017-20061?

2 open source packages ship an affected version, including elefant/cms. It affects 1 product.

PackageAffectedFixed in
elefant/cms PackagistAll versions1.3.13
elefant/cms PackagistAll versions1.3.13

Products include Elefantcms Elefant Cms.

How do I fix CVE-2017-20061?

Upgrade elefant/cms to 1.3.13 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-20061 being exploited?

There is no known exploitation of CVE-2017-20061 in the wild and no public exploit code.

Sources

Also known as GHSA-hgm9-pww2-93pc.

Is CVE-2017-20061 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free