# CVE-2017-20061: Elefant CMS extended Reflected cross site scriting

> Reflected cross-site scripting in Elefant CMS allows remote attackers to inject malicious scripts via the name argument in the admin extended page.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jun 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-hgm9-pww2-93pc

## What is CVE-2017-20061?

CVE-2017-20061 is a medium-severity cross-site scripting vulnerability in Elefant CMS, published on 20 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability has been found in Elefant CMS 1.3.12-RC and classified as problematic. This vulnerability affects unknown code of the file /admin/extended. The manipulation of the argument name with the input %3Cimg%20src=no%20onerror=alert(1)%3E leads to basic cross site scripting (Reflected). The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.3.13 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2017-20061?

2 open source packages ship an affected version, including elefant/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elefant/cms` | Packagist | All versions | 1.3.13 |
| `elefant/cms` | Packagist | All versions | 1.3.13 |

Products: Elefantcms Elefant Cms.

## How do I fix CVE-2017-20061?

Upgrade elefant/cms to 1.3.13 or later.

## Is CVE-2017-20061 being exploited?

There is no known exploitation of CVE-2017-20061 in the wild and no public exploit code.

## Other vulnerabilities in Elefant CMS

- [CVE-2017-20063](https://insights.sbomify.com/CVE-2017-20063/): Elefant CMS File Upload drop privileges management (medium 6.3)
- [CVE-2017-20064](https://insights.sbomify.com/CVE-2017-20064/): Elefant CMS layout code injection (medium 6.3)
- [CVE-2017-20062](https://insights.sbomify.com/CVE-2017-20062/): Elefant CMS cross-site request forgery (medium 5.0)
- [CVE-2017-20057](https://insights.sbomify.com/CVE-2017-20057/): Elefant CMS Persistent cross site scriting (medium 4.3)
- [CVE-2017-20059](https://insights.sbomify.com/CVE-2017-20059/): Elefant CMS Title Persistent cross site scriting (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-20061 and fix it if it is affected.

What it is: CVE-2017-20061 is a medium-severity cross-site scripting vulnerability in Elefant CMS, published on 20 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-20061 in the wild and no public exploit code.

Affected packages and fixed versions:
- elefant/cms (Packagist): affected all versions; fixed in 1.3.13
- elefant/cms (Packagist): affected all versions; fixed in 1.3.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-20061/ (Markdown: https://insights.sbomify.com/CVE-2017-20061/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-20061
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-20061
- OSV: https://osv.dev/vulnerability/CVE-2017-20061

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-20061/
Summaries are generated and may contain mistakes; the official description above is the record.
