# CVE-2017-20062: Elefant CMS cross-site request forgery

> Attackers can perform unauthorized actions on behalf of authenticated users in Elefant CMS via cross-site request forgery.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Jun 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-pq7f-cq6q-94xh

## What is CVE-2017-20062?

CVE-2017-20062 is a medium-severity vulnerability in Elefant CMS, published on 20 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in Elefant CMS 1.3.12-RC and classified as problematic. This issue affects some unknown processing. The manipulation leads to cross-site request forgery. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.3.13 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2017-20062?

2 open source packages ship an affected version, including elefant/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elefant/cms` | Packagist | All versions | 1.3.13 |
| `elefant/cms` | Packagist | All versions | 1.3.13 |

Products: Elefantcms Elefant Cms.

## How do I fix CVE-2017-20062?

Upgrade elefant/cms to 1.3.13 or later.

## Is CVE-2017-20062 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-20062 exists.

## Other vulnerabilities in Elefant CMS

- [CVE-2017-20063](https://insights.sbomify.com/CVE-2017-20063/): Elefant CMS File Upload drop privileges management (medium 6.3)
- [CVE-2017-20064](https://insights.sbomify.com/CVE-2017-20064/): Elefant CMS layout code injection (medium 6.3)
- [CVE-2017-20057](https://insights.sbomify.com/CVE-2017-20057/): Elefant CMS Persistent cross site scriting (medium 4.3)
- [CVE-2017-20061](https://insights.sbomify.com/CVE-2017-20061/): Elefant CMS extended Reflected cross site scriting (medium 4.3)
- [CVE-2017-20059](https://insights.sbomify.com/CVE-2017-20059/): Elefant CMS Title Persistent cross site scriting (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-20062 and fix it if it is affected.

What it is: CVE-2017-20062 is a medium-severity vulnerability in Elefant CMS, published on 20 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-20062 exists.

Affected packages and fixed versions:
- elefant/cms (Packagist): affected all versions; fixed in 1.3.13
- elefant/cms (Packagist): affected all versions; fixed in 1.3.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-20062/ (Markdown: https://insights.sbomify.com/CVE-2017-20062/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-20062
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-20062
- OSV: https://osv.dev/vulnerability/CVE-2017-20062

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-20062/
Summaries are generated and may contain mistakes; the official description above is the record.
