CVE-2017-20064 Elefant CMS layout code injection

Medium 6.3 Published Updated

Remote attackers can inject arbitrary code via the layout designer functionality in Elefant CMS, leading to potential system compromise.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-20064?

CVE-2017-20064 is a medium-severity code injection vulnerability in Elefant CMS, published on 20 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was found in Elefant CMS 1.3.12-RC. It has been declared as critical. Affected by this vulnerability is an unknown functionality of the file /designer/add/layout. The manipulation leads to code injection. The attack can be launched remotely. Upgrading to version 1.3.13 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-94

Which versions are affected by CVE-2017-20064?

2 open source packages ship an affected version, including elefant/cms. It affects 1 product.

PackageAffectedFixed in
elefant/cms PackagistAll versions1.3.13
elefant/cms PackagistAll versions1.3.13

Products include Elefantcms Elefant Cms.

How do I fix CVE-2017-20064?

Upgrade elefant/cms to 1.3.13 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2017-20064 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-20064 exists.

Sources

Also known as GHSA-gx6v-67qv-rhx5.

Is CVE-2017-20064 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free