{"answers":{"affected":"2 open source packages ship an affected version, including elefant/cms. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-20064 exists.","fix":"Upgrade elefant/cms to 1.3.13 or later.","what":"CVE-2017-20064 is a medium-severity code injection vulnerability in Elefant CMS, published on 20 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-20064 and fix it if it is affected.\n\nWhat it is: CVE-2017-20064 is a medium-severity code injection vulnerability in Elefant CMS, published on 20 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-20064 exists.\n\nAffected packages and fixed versions:\n- elefant/cms (Packagist): affected all versions; fixed in 1.3.13\n- elefant/cms (Packagist): affected all versions; fixed in 1.3.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20064/ (Markdown: https://insights.sbomify.com/CVE-2017-20064/index.md)","id":"CVE-2017-20064","markdown":"https://insights.sbomify.com/CVE-2017-20064/index.md","name":"CVE-2017-20064","record":{"aliases":["GHSA-gx6v-67qv-rhx5"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Elefant CMS","requires_auth":"low_privilege","summary":"Remote attackers can inject arbitrary code via the layout designer functionality in Elefant CMS, leading to potential system compromise.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"elefant_cms","vendor":"elefantcms"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"A vulnerability was found in Elefant CMS 1.3.12-RC. It has been declared as critical. Affected by this vulnerability is an unknown functionality of the file /designer/add/layout. The manipulation leads to code injection. The attack can be launched remotely. Upgrading to version 1.3.13 is able to address this issue. It is recommended to upgrade the affected component.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Elefant CMS layout code injection","id":"CVE-2017-20064","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Supsystic Popup Plugin cross-site request forgery","id":"CVE-2017-20065"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.13"],"introduced":["0"],"last_affected":[],"package":"elefant/cms","purl":null,"source":"GHSA-gx6v-67qv-rhx5"},{"ecosystem":"Packagist","fixed":["1.3.13"],"introduced":["0"],"last_affected":[],"package":"elefant/cms","purl":"pkg:composer/elefant/cms","source":"GHSA-gx6v-67qv-rhx5"}],"prev":{"headline":"Elefant CMS File Upload drop privileges management","id":"CVE-2017-20063"},"products":["CMS"],"published":"2022-06-20","related":[{"cvss_score":6.3,"headline":"Elefant CMS File Upload drop privileges management","id":"CVE-2017-20063","kev_date_added":null,"published":"2022-06-20"},{"cvss_score":5,"headline":"Elefant CMS cross-site request forgery","id":"CVE-2017-20062","kev_date_added":null,"published":"2022-06-20"},{"cvss_score":4.3,"headline":"Elefant CMS Persistent cross site scriting","id":"CVE-2017-20057","kev_date_added":null,"published":"2022-06-20"},{"cvss_score":4.3,"headline":"Elefant CMS extended Reflected cross site scriting","id":"CVE-2017-20061","kev_date_added":null,"published":"2022-06-20"},{"cvss_score":3.5,"headline":"Elefant CMS Title Persistent cross site scriting","id":"CVE-2017-20059","kev_date_added":null,"published":"2022-06-20"},{"cvss_score":3.5,"headline":"Elefant CMS Blog Post Persistent cross site scriting","id":"CVE-2017-20060","kev_date_added":null,"published":"2022-06-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["Elefant"]},"summary":"Remote attackers can inject arbitrary code via the layout designer functionality in Elefant CMS, leading to potential system compromise.","url":"https://insights.sbomify.com/CVE-2017-20064/"}