# CVE-2017-20103: Kama Click Counter Plugin admin.php Blind sql injection

> Remote attackers can perform blind SQL injection via the admin.php file in the Kama Click Counter Plugin, potentially exposing database information.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Jun 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-283c-28ph-cjjp

## What is CVE-2017-20103?

CVE-2017-20103 is a medium-severity SQL injection vulnerability in unspecified Kama Click Counter Plugin, published on 27 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability classified as critical has been found in Kama Click Counter Plugin up to 3.4.8. This affects an unknown part of the file wp-admin/admin.php. The manipulation of the argument order_by/order with the input ASC%2c(select*from(select(sleep(2)))a) leads to sql injection (Blind). It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.4.9 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2017-20103?

It affects 1 product.


Products: Wp-Kama Kama Click Counter.

## How do I fix CVE-2017-20103?

No fix has been published for CVE-2017-20103 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-20103 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-20103 exists.

## Other vulnerabilities in unspecified Kama Click Counter Plugin

- [CVE-2017-18614](https://insights.sbomify.com/CVE-2017-18614/): SQL injection in n/a (high 8.1)
- [CVE-2017-18615](https://insights.sbomify.com/CVE-2017-18615/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-20103 and fix it if it is affected.

What it is: CVE-2017-20103 is a medium-severity SQL injection vulnerability in unspecified Kama Click Counter Plugin, published on 27 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-20103 exists.

Affected product: unspecified Kama Click Counter Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-20103/ (Markdown: https://insights.sbomify.com/CVE-2017-20103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-20103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-20103
- OSV: https://osv.dev/vulnerability/CVE-2017-20103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-20103/
Summaries are generated and may contain mistakes; the official description above is the record.
