{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20155 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2017-20155 yet. Limit exposure of the affected software until one is available.","what":"CVE-2017-20155 is a low-severity cross-site scripting vulnerability in Sterc Google Analytics Dashboard for MODX, published on 30 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-20155 and fix it if it is affected.\n\nWhat it is: CVE-2017-20155 is a low-severity cross-site scripting vulnerability in Sterc Google Analytics Dashboard for MODX, published on 30 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-20155 in the wild and no public exploit code.\n\nAffected product: Sterc Google Analytics Dashboard for MODX. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20155/ (Markdown: https://insights.sbomify.com/CVE-2017-20155/index.md)","id":"CVE-2017-20155","markdown":"https://insights.sbomify.com/CVE-2017-20155/index.md","name":"CVE-2017-20155","record":{"aliases":["GHSA-xcqg-3g54-56vr"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MODX analytics plugin","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts via the Internal Search widget in the Sterc Google Analytics Dashboard for MODX plugin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"google_analytics_dashboard_for_modx","vendor":"sterc"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in Sterc Google Analytics Dashboard for MODX up to 1.0.5. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file core/components/analyticsdashboardwidget/elements/tpl/widget.analytics.tpl of the component Internal Search. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.0.6 is able to address this issue. The identifier of the patch is 855d9560d3782c105568eedf9b22a769fbf29cc0. It is recommended to upgrade the affected component. The identifier VDB-217069 was assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Sterc Google Analytics Dashboard for MODX Internal Search widget.analytics.tpl cross site scripting","id":"CVE-2017-20155","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2017"},"n_packages":0,"n_references":6,"next":{"headline":"Exciting Printer Argument prepare_page.rb command injection","id":"CVE-2017-20156"},"packages":[],"prev":{"headline":"ghostlander Phoenixcoin main.cpp accept denial of service","id":"CVE-2017-20154"},"products":["Google Analytics Dashboard for MODX"],"published":"2022-12-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Sterc"]},"summary":"Remote attackers can inject malicious scripts via the Internal Search widget in the Sterc Google Analytics Dashboard for MODX plugin.","url":"https://insights.sbomify.com/CVE-2017-20155/"}