{"answers":{"affected":"2 open source packages ship an affected version, including arc/web. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20157 in the wild and no public exploit code.","fix":"Upgrade arc/web to 3.0 or later.","what":"CVE-2017-20157 is a medium-severity server-side request forgery vulnerability in Ariadne Component Library, published on 31 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-20157 and fix it if it is affected.\n\nWhat it is: CVE-2017-20157 is a medium-severity server-side request forgery vulnerability in Ariadne Component Library, published on 31 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-20157 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- arc/web (Packagist): affected all versions; fixed in 3.0\n- arc/web (Packagist): affected all versions; fixed in 3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20157/ (Markdown: https://insights.sbomify.com/CVE-2017-20157/index.md)","id":"CVE-2017-20157","markdown":"https://insights.sbomify.com/CVE-2017-20157/index.md","name":"CVE-2017-20157","record":{"aliases":["GHSA-qr97-v87p-x965"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PHP URL library","requires_auth":"low_privilege","summary":"Attackers can exploit a server-side request forgery flaw in the Ariadne Component Library to access internal resources or bypass security controls.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"ariadne_component_library","vendor":"ariadne-cms"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"A vulnerability was found in Ariadne Component Library up to 2.x. It has been classified as critical. Affected is an unknown function of the file src/url/Url.php. The manipulation leads to server-side request forgery. Upgrading to version 3.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217140.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ariadne Component Library Url.php server-side request forgery","id":"CVE-2017-20157","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"ssrf","year":"2017"},"n_packages":2,"n_references":4,"next":{"headline":"vova07 Yii2 FileAPI Widget UploadAction.php run cross site scripting","id":"CVE-2017-20158"},"packages":[{"ecosystem":"Packagist","fixed":["3.0"],"introduced":["0"],"last_affected":[],"package":"arc/web","purl":null,"source":"GHSA-qr97-v87p-x965"},{"ecosystem":"Packagist","fixed":["3.0"],"introduced":["0"],"last_affected":[],"package":"arc/web","purl":"pkg:composer/arc/web","source":"GHSA-qr97-v87p-x965"}],"prev":{"headline":"Exciting Printer Argument prepare_page.rb command injection","id":"CVE-2017-20156"},"products":["Component Library"],"published":"2022-12-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Ariadne"]},"summary":"Attackers can exploit a server-side request forgery flaw in the Ariadne Component Library to access internal resources or bypass security controls.","url":"https://insights.sbomify.com/CVE-2017-20157/"}