CVE-2017-20158 vova07 Yii2 FileAPI Widget UploadAction.php run cross site scripting

Low 3.5 Published Updated

An attacker can inject malicious scripts via file upload arguments in the Yii2 FileAPI Widget, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-20158?

CVE-2017-20158 is a low-severity cross-site scripting vulnerability in vova07 Yii2 FileAPI Widget, published on 31 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in vova07 Yii2 FileAPI Widget up to 0.1.8. It has been declared as problematic. Affected by this vulnerability is the function run of the file actions/UploadAction.php. The manipulation of the argument file leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.1.9 is able to address this issue. The identifier of the patch is c00d1e4fc912257fca1fce66d7a163bdbb4c8222. It is recommended to upgrade the affected component. The identifier VDB-217141 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-79

Which versions are affected by CVE-2017-20158?

2 open source packages ship an affected version, including vova07/yii2-fileapi-widget. It affects 1 product.

PackageAffectedFixed in
vova07/yii2-fileapi-widget PackagistAll versions0.1.9
vova07/yii2-fileapi-widget PackagistAll versions0.1.9

Products include Yii2 Fileapi Widget Project Yii2 Fileapi Widget.

How do I fix CVE-2017-20158?

Upgrade vova07/yii2-fileapi-widget to 0.1.9 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-20158 being exploited?

There is no known exploitation of CVE-2017-20158 in the wild and no public exploit code.

Sources

Also known as GHSA-j82x-fh8h-326g.

Is CVE-2017-20158 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free