{"answers":{"affected":"2 open source packages ship an affected version, including vova07/yii2-fileapi-widget. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20158 in the wild and no public exploit code.","fix":"Upgrade vova07/yii2-fileapi-widget to 0.1.9 or later.","what":"CVE-2017-20158 is a low-severity cross-site scripting vulnerability in vova07 Yii2 FileAPI Widget, published on 31 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-20158 and fix it if it is affected.\n\nWhat it is: CVE-2017-20158 is a low-severity cross-site scripting vulnerability in vova07 Yii2 FileAPI Widget, published on 31 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-20158 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vova07/yii2-fileapi-widget (Packagist): affected all versions; fixed in 0.1.9\n- vova07/yii2-fileapi-widget (Packagist): affected all versions; fixed in 0.1.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20158/ (Markdown: https://insights.sbomify.com/CVE-2017-20158/index.md)","id":"CVE-2017-20158","markdown":"https://insights.sbomify.com/CVE-2017-20158/index.md","name":"CVE-2017-20158","record":{"aliases":["GHSA-j82x-fh8h-326g"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"Yii2 FileAPI Widget","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts via file upload arguments in the Yii2 FileAPI Widget, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"yii2_fileapi_widget","vendor":"yii2_fileapi_widget_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in vova07 Yii2 FileAPI Widget up to 0.1.8. It has been declared as problematic. Affected by this vulnerability is the function run of the file actions/UploadAction.php. The manipulation of the argument file leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.1.9 is able to address this issue. The identifier of the patch is c00d1e4fc912257fca1fce66d7a163bdbb4c8222. It is recommended to upgrade the affected component. The identifier VDB-217141 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vova07 Yii2 FileAPI Widget UploadAction.php run cross site scripting","id":"CVE-2017-20158","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":4,"next":{"headline":"rf Keynote rumble.rb cross site scripting","id":"CVE-2017-20159"},"packages":[{"ecosystem":"Packagist","fixed":["0.1.9"],"introduced":["0"],"last_affected":[],"package":"vova07/yii2-fileapi-widget","purl":null,"source":"GHSA-j82x-fh8h-326g"},{"ecosystem":"Packagist","fixed":["0.1.9"],"introduced":["0"],"last_affected":[],"package":"vova07/yii2-fileapi-widget","purl":"pkg:composer/vova07/yii2-fileapi-widget","source":"GHSA-j82x-fh8h-326g"}],"prev":{"headline":"Ariadne Component Library Url.php server-side request forgery","id":"CVE-2017-20157"},"products":["Yii2 FileAPI Widget"],"published":"2022-12-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["vova07"]},"summary":"An attacker can inject malicious scripts via file upload arguments in the Yii2 FileAPI Widget, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2017-20158/"}