{"answers":{"affected":"2 open source packages ship an affected version, including keynote. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20159 in the wild and no public exploit code.","fix":"Upgrade keynote to 1.0.0 or later.","what":"CVE-2017-20159 is a low-severity cross-site scripting vulnerability in rf Keynote, published on 31 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-20159 and fix it if it is affected.\n\nWhat it is: CVE-2017-20159 is a low-severity cross-site scripting vulnerability in rf Keynote, published on 31 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-20159 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- keynote (RubyGems): affected all versions; fixed in 1.0.0\n- keynote (RubyGems): affected all versions; fixed in 1.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20159/ (Markdown: https://insights.sbomify.com/CVE-2017-20159/index.md)","id":"CVE-2017-20159","markdown":"https://insights.sbomify.com/CVE-2017-20159/index.md","name":"CVE-2017-20159","record":{"aliases":["GHSA-399p-vq28-5hg8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Keynote library","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via the value argument in the Keynote Ruby library, potentially executing code in user browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"keynote","vendor":"keynote_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in rf Keynote up to 0.x on Rails. It has been rated as problematic. Affected by this issue is some unknown functionality of the file lib/keynote/rumble.rb. The manipulation of the argument value leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.0.0 is able to address this issue. The patch is identified as 05be4356b0a6ca7de48da926a9b997beb5ffeb4a. It is recommended to upgrade the affected component. VDB-217142 is the identifier assigned to this vulnerability.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"rf Keynote rumble.rb cross site scripting","id":"CVE-2017-20159","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":4,"next":{"headline":"flitto express-param fetchParams.js parameter pollution","id":"CVE-2017-20160"},"packages":[{"ecosystem":"RubyGems","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"keynote","purl":null,"source":"GHSA-399p-vq28-5hg8"},{"ecosystem":"RubyGems","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"keynote","purl":"pkg:gem/keynote","source":"GHSA-399p-vq28-5hg8"}],"prev":{"headline":"vova07 Yii2 FileAPI Widget UploadAction.php run cross site scripting","id":"CVE-2017-20158"},"products":["Keynote"],"published":"2022-12-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-15","vendors":["rf"]},"summary":"Attackers can inject malicious scripts via the value argument in the Keynote Ruby library, potentially executing code in user browsers.","url":"https://insights.sbomify.com/CVE-2017-20159/"}