# CVE-2017-20159: rf Keynote rumble.rb cross site scripting

> Attackers can inject malicious scripts via the value argument in the Keynote Ruby library, potentially executing code in user browsers.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Dec 2022
- **Updated:** 15 Oct 2024
- **Also known as:** GHSA-399p-vq28-5hg8

## What is CVE-2017-20159?

CVE-2017-20159 is a low-severity cross-site scripting vulnerability in rf Keynote, published on 31 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in rf Keynote up to 0.x on Rails. It has been rated as problematic. Affected by this issue is some unknown functionality of the file lib/keynote/rumble.rb. The manipulation of the argument value leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.0.0 is able to address this issue. The patch is identified as 05be4356b0a6ca7de48da926a9b997beb5ffeb4a. It is recommended to upgrade the affected component. VDB-217142 is the identifier assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-20159?

2 open source packages ship an affected version, including keynote. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keynote` | RubyGems | All versions | 1.0.0 |
| `keynote` | RubyGems | All versions | 1.0.0 |

Products: Keynote Project Keynote.

## How do I fix CVE-2017-20159?

Upgrade keynote to 1.0.0 or later.

## Is CVE-2017-20159 being exploited?

There is no known exploitation of CVE-2017-20159 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-20159 and fix it if it is affected.

What it is: CVE-2017-20159 is a low-severity cross-site scripting vulnerability in rf Keynote, published on 31 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-20159 in the wild and no public exploit code.

Affected packages and fixed versions:
- keynote (RubyGems): affected all versions; fixed in 1.0.0
- keynote (RubyGems): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-20159/ (Markdown: https://insights.sbomify.com/CVE-2017-20159/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-20159
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-20159
- OSV: https://osv.dev/vulnerability/CVE-2017-20159

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-20159/
Summaries are generated and may contain mistakes; the official description above is the record.
