{"answers":{"affected":"2 open source packages ship an affected version, including express-param. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20160 in the wild and no public exploit code.","fix":"Upgrade express-param to 1.0.0 or later.","what":"CVE-2017-20160 is a medium-severity vulnerability in flitto express-param, published on 31 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-20160 and fix it if it is affected.\n\nWhat it is: CVE-2017-20160 is a medium-severity vulnerability in flitto express-param, published on 31 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-20160 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- express-param (npm): affected all versions; fixed in 1.0.0\n- express-param (npm): affected all versions; fixed in 1.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20160/ (Markdown: https://insights.sbomify.com/CVE-2017-20160/index.md)","id":"CVE-2017-20160","markdown":"https://insights.sbomify.com/CVE-2017-20160/index.md","name":"CVE-2017-20160","record":{"aliases":["GHSA-fr54-72wr-cqvq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js parameter library","requires_auth":"low_privilege","summary":"Remote attackers can exploit improper parameter handling in express-param to manipulate application logic or bypass security controls.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"express-param","vendor":"flitto"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-235","name":"Improper Handling of Extra Parameters"}],"description":"A vulnerability was found in flitto express-param up to 0.x. It has been classified as critical. This affects an unknown part of the file lib/fetchParams.js. The manipulation leads to improper handling of extra parameters. It is possible to initiate the attack remotely. Upgrading to version 1.0.0 is able to address this issue. The identifier of the patch is db94f7391ad0a16dcfcba8b9be1af385b25c42db. It is recommended to upgrade the affected component. The identifier VDB-217149 was assigned to this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"flitto express-param fetchParams.js parameter pollution","id":"CVE-2017-20160","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2017"},"n_packages":2,"n_references":5,"next":{"headline":"rofl0r MacGeiger ESSID macgeiger.c dump_wlan_at injection","id":"CVE-2017-20161"},"packages":[{"ecosystem":"npm","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"express-param","purl":null,"source":"GHSA-fr54-72wr-cqvq"},{"ecosystem":"npm","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"express-param","purl":"pkg:npm/express-param","source":"GHSA-fr54-72wr-cqvq"}],"prev":{"headline":"rf Keynote rumble.rb cross site scripting","id":"CVE-2017-20159"},"products":["express-param"],"published":"2022-12-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["flitto"]},"summary":"Remote attackers can exploit improper parameter handling in express-param to manipulate application logic or bypass security controls.","url":"https://insights.sbomify.com/CVE-2017-20160/"}