# CVE-2017-20160: flitto express-param fetchParams.js parameter pollution

> Remote attackers can exploit improper parameter handling in express-param to manipulate application logic or bypass security controls.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2022
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-fr54-72wr-cqvq

## What is CVE-2017-20160?

CVE-2017-20160 is a medium-severity vulnerability in flitto express-param, published on 31 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in flitto express-param up to 0.x. It has been classified as critical. This affects an unknown part of the file lib/fetchParams.js. The manipulation leads to improper handling of extra parameters. It is possible to initiate the attack remotely. Upgrading to version 1.0.0 is able to address this issue. The identifier of the patch is db94f7391ad0a16dcfcba8b9be1af385b25c42db. It is recommended to upgrade the affected component. The identifier VDB-217149 was assigned to this vulnerability.

Weakness: CWE-235 (Improper Handling of Extra Parameters)

## Which versions are affected by CVE-2017-20160?

2 open source packages ship an affected version, including express-param. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `express-param` | npm | All versions | 1.0.0 |
| `express-param` | npm | All versions | 1.0.0 |

Products: Flitto Express-Param.

## How do I fix CVE-2017-20160?

Upgrade express-param to 1.0.0 or later.

## Is CVE-2017-20160 being exploited?

There is no known exploitation of CVE-2017-20160 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-20160 and fix it if it is affected.

What it is: CVE-2017-20160 is a medium-severity vulnerability in flitto express-param, published on 31 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-20160 in the wild and no public exploit code.

Affected packages and fixed versions:
- express-param (npm): affected all versions; fixed in 1.0.0
- express-param (npm): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-20160/ (Markdown: https://insights.sbomify.com/CVE-2017-20160/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-20160
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-20160
- OSV: https://osv.dev/vulnerability/CVE-2017-20160

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-20160/
Summaries are generated and may contain mistakes; the official description above is the record.
