{"answers":{"affected":"2 open source packages ship an affected version, including ms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20162 in the wild and no public exploit code.","fix":"Upgrade ms to 2.0.0 or later.","what":"CVE-2017-20162 is a medium-severity denial of service vulnerability in vercel ms, published on 5 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-20162 and fix it if it is affected.\n\nWhat it is: CVE-2017-20162 is a medium-severity denial of service vulnerability in vercel ms, published on 5 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-20162 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ms (npm): affected all versions; fixed in 2.0.0\n- ms (npm): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20162/ (Markdown: https://insights.sbomify.com/CVE-2017-20162/index.md)","id":"CVE-2017-20162","markdown":"https://insights.sbomify.com/CVE-2017-20162/index.md","name":"CVE-2017-20162","record":{"aliases":["AZL-43849","AZL-44002","AZL-45126","AZL-45201","CLSA-2026-1773360972","CLSA-2026-1776991063","CLSA-2026-1776991064","CLSA-2026-1776991065","CLSA-2026-1784596309","CLSA-2026-1793303909","GHSA-w9mr-4mfr-499f","UBUNTU-CVE-2017-20162"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript time library","requires_auth":"low_privilege","summary":"Remote attackers can cause denial of service in the vercel ms library via inefficient regular expression complexity in the parse function.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"ms","vendor":"vercel"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"A vulnerability, which was classified as problematic, has been found in vercel ms up to 1.x. This issue affects the function parse of the file index.js. The manipulation of the argument str leads to inefficient regular expression complexity. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named caae2988ba2a37765d055c4eee63d383320ee662. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217451.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vercel ms index.js parse redos","id":"CVE-2017-20162","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":5,"next":{"headline":"Red Snapper NView Session.php mutate sql injection","id":"CVE-2017-20163"},"packages":[{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"ms","purl":null,"source":"GHSA-w9mr-4mfr-499f"},{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"ms","purl":"pkg:npm/ms","source":"GHSA-w9mr-4mfr-499f"}],"prev":{"headline":"rofl0r MacGeiger ESSID macgeiger.c dump_wlan_at injection","id":"CVE-2017-20161"},"products":["ms"],"published":"2023-01-05","related":[{"cvss_score":7.5,"headline":"Regular Expression Denial of Service in ms","id":"CVE-2015-8315","kev_date_added":null,"published":"2017-01-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-15","vendors":["vercel"]},"summary":"Remote attackers can cause denial of service in the vercel ms library via inefficient regular expression complexity in the parse function.","url":"https://insights.sbomify.com/CVE-2017-20162/"}