# CVE-2017-20164: Symbiote Seed Login SecurityLoginExtension.php onBeforeSecurityLogin redirect


- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 Jan 2023
- **Updated:** 8 Apr 2025
- **Also known as:** GHSA-wm32-3r4m-jvcc

## What is CVE-2017-20164?

CVE-2017-20164 is a medium-severity vulnerability in Symbiote Seed, published on 7 Jan 2023. 

### Official description

A vulnerability was found in Symbiote Seed up to 6.0.2. It has been classified as critical. Affected is the function onBeforeSecurityLogin of the file code/extensions/SecurityLoginExtension.php of the component Login. The manipulation of the argument URL leads to open redirect. It is possible to launch the attack remotely. Upgrading to version 6.0.3 is able to address this issue. The patch is identified as b065ebd82da53009d273aa7e989191f701485244. It is recommended to upgrade the affected component. VDB-217626 is the identifier assigned to this vulnerability.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2017-20164?

2 open source packages ship an affected version, including symbiote/silverstripe-seed. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symbiote/silverstripe-seed` | Packagist | All versions | 6.0.3 |
| `symbiote/silverstripe-seed` | Packagist | All versions | 6.0.3 |

Products: Symbiote Seed.

## How do I fix CVE-2017-20164?

Upgrade symbiote/silverstripe-seed to 6.0.3 or later.

## Is CVE-2017-20164 being exploited?

There is no known exploitation of CVE-2017-20164 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-20164 and fix it if it is affected.

What it is: CVE-2017-20164 is a medium-severity vulnerability in Symbiote Seed, published on 7 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2017-20164 in the wild and no public exploit code.

Affected packages and fixed versions:
- symbiote/silverstripe-seed (Packagist): affected all versions; fixed in 6.0.3
- symbiote/silverstripe-seed (Packagist): affected all versions; fixed in 6.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-20164/ (Markdown: https://insights.sbomify.com/CVE-2017-20164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-20164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-20164
- OSV: https://osv.dev/vulnerability/CVE-2017-20164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-20164/
Summaries are generated and may contain mistakes; the official description above is the record.
