{"answers":{"affected":"2 open source packages ship an affected version, including mediawiki/matomo. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20175 in the wild and no public exploit code.","fix":"Upgrade mediawiki/matomo to 2.4.3 or later.","what":"CVE-2017-20175 is a low-severity cross-site scripting vulnerability in DaSchTour matomo-mediawiki-extension, published on 5 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-20175 and fix it if it is affected.\n\nWhat it is: CVE-2017-20175 is a low-severity cross-site scripting vulnerability in DaSchTour matomo-mediawiki-extension, published on 5 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-20175 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mediawiki/matomo (Packagist): affected all versions; fixed in 2.4.3\n- mediawiki/matomo (Packagist): affected all versions; fixed in 2.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20175/ (Markdown: https://insights.sbomify.com/CVE-2017-20175/index.md)","id":"CVE-2017-20175","markdown":"https://insights.sbomify.com/CVE-2017-20175/index.md","name":"CVE-2017-20175","record":{"aliases":["GHSA-hc67-v29c-7g78"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki extension","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts via cross-site scripting in the Matomo MediaWiki extension username handler.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"matomo","vendor":"mediawiki"}],"cvss":{"score":2.6,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability classified as problematic has been found in DaSchTour matomo-mediawiki-extension up to 2.4.2 on MediaWiki. This affects an unknown part of the file Piwik.hooks.php of the component Username Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 2.4.3 is able to address this issue. The patch is named 681324e4f518a8af4bd1f93867074c728eb9923d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220203.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DaSchTour matomo-mediawiki-extension Username Piwik.hooks.php cross site scripting","id":"CVE-2017-20175","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":5,"next":{"headline":"ciubotaru share-on-diaspora new_window.php cross site scripting","id":"CVE-2017-20176"},"packages":[{"ecosystem":"Packagist","fixed":["2.4.3"],"introduced":["0"],"last_affected":[],"package":"mediawiki/matomo","purl":null,"source":"GHSA-hc67-v29c-7g78"},{"ecosystem":"Packagist","fixed":["2.4.3"],"introduced":["0"],"last_affected":[],"package":"mediawiki/matomo","purl":"pkg:composer/mediawiki/matomo","source":"GHSA-hc67-v29c-7g78"}],"prev":{"headline":"bastianallgeier Kirby Webmentions Plugin injection","id":"CVE-2017-20174"},"products":["matomo-mediawiki-extension"],"published":"2023-02-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["DaSchTour"]},"summary":"Remote attackers can execute arbitrary scripts via cross-site scripting in the Matomo MediaWiki extension username handler.","url":"https://insights.sbomify.com/CVE-2017-20175/"}