CVE-2017-20178 Codiad process.php saveJSON information disclosure

Low 3.1 Published Updated

Remote attackers can exploit the saveJSON function in Codiad to disclose sensitive information, requiring high complexity and permissions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-20178?

CVE-2017-20178 is a low-severity vulnerability in Codiad, published on 21 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in Codiad 2.8.0. It has been rated as problematic. Affected by this issue is the function saveJSON of the file components/install/process.php. The manipulation of the argument data leads to information disclosure. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 2.8.1 is able to address this issue. The patch is identified as 517119de673e62547ee472a730be0604f44342b5. It is recommended to upgrade the affected component. VDB-221498 is the identifier assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-200

Which versions are affected by CVE-2017-20178?

2 open source packages ship an affected version, including codiad/codiad. It affects 1 product.

PackageAffectedFixed in
codiad/codiad PackagistAll versions2.8.1
codiad/codiad PackagistAll versions2.8.1

Products include Codiad Codiad.

How do I fix CVE-2017-20178?

Upgrade codiad/codiad to 2.8.1 or later.

Is CVE-2017-20178 being exploited?

There is no known exploitation of CVE-2017-20178 in the wild and no public exploit code.

Sources

Also known as GHSA-2q79-56rq-8v3c.

Is CVE-2017-20178 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free