{"answers":{"affected":"2 open source packages ship an affected version, including codiad/codiad. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20178 in the wild and no public exploit code.","fix":"Upgrade codiad/codiad to 2.8.1 or later.","what":"CVE-2017-20178 is a low-severity vulnerability in Codiad, published on 21 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-20178 and fix it if it is affected.\n\nWhat it is: CVE-2017-20178 is a low-severity vulnerability in Codiad, published on 21 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-20178 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codiad/codiad (Packagist): affected all versions; fixed in 2.8.1\n- codiad/codiad (Packagist): affected all versions; fixed in 2.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20178/ (Markdown: https://insights.sbomify.com/CVE-2017-20178/index.md)","id":"CVE-2017-20178","markdown":"https://insights.sbomify.com/CVE-2017-20178/index.md","name":"CVE-2017-20178","record":{"aliases":["GHSA-2q79-56rq-8v3c"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Codiad web IDE","requires_auth":"low_privilege","summary":"Remote attackers can exploit the saveJSON function in Codiad to disclose sensitive information, requiring high complexity and permissions.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"codiad","vendor":"codiad"}],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in Codiad 2.8.0. It has been rated as problematic. Affected by this issue is the function saveJSON of the file components/install/process.php. The manipulation of the argument data leads to information disclosure. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 2.8.1 is able to address this issue. The patch is identified as 517119de673e62547ee472a730be0604f44342b5. It is recommended to upgrade the affected component. VDB-221498 is the identifier assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Codiad process.php saveJSON information disclosure","id":"CVE-2017-20178","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2017"},"n_packages":2,"n_references":5,"next":{"headline":"InSTEDD Pollit tour_controller.rb TourController Privilege Escalation","id":"CVE-2017-20179"},"packages":[{"ecosystem":"Packagist","fixed":["2.8.1"],"introduced":["0"],"last_affected":[],"package":"codiad/codiad","purl":null,"source":"GHSA-2q79-56rq-8v3c"},{"ecosystem":"Packagist","fixed":["2.8.1"],"introduced":["0"],"last_affected":[],"package":"codiad/codiad","purl":"pkg:composer/codiad/codiad","source":"GHSA-2q79-56rq-8v3c"}],"prev":{"headline":"WangGuard Plugin WGG User List wangguard-user-info.php wangguard_users_info cross site scripting","id":"CVE-2017-20177"},"products":["Codiad"],"published":"2023-02-21","related":[{"cvss_score":9.8,"headline":"Code injection in codiad","id":"CVE-2019-19208","kev_date_added":null,"published":"2020-03-16"},{"cvss_score":9.8,"headline":"Codiad remote code execution vulnerability","id":"CVE-2018-14009","kev_date_added":null,"published":"2018-07-12"},{"cvss_score":9.8,"headline":"Codiad Vulnerable to Shell Command Injection","id":"CVE-2017-11366","kev_date_added":null,"published":"2017-08-21"},{"cvss_score":8.8,"headline":"Codiad CSRF Vulnerability","id":"CVE-2020-14043","kev_date_added":null,"published":"2020-08-24"},{"cvss_score":7.5,"headline":"Codiad Vulnerable to PHP Magic Hash Vulnerability","id":"CVE-2020-23355","kev_date_added":null,"published":"2021-01-27"},{"cvss_score":7.5,"headline":"File upload in n/a","id":"CVE-2017-1000125","kev_date_added":null,"published":"2017-11-17"},{"cvss_score":7.2,"headline":"Codiad SSRF Vulnerability","id":"CVE-2020-14044","kev_date_added":null,"published":"2020-08-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can exploit the saveJSON function in Codiad to disclose sensitive information, requiring high complexity and permissions.","url":"https://insights.sbomify.com/CVE-2017-20178/"}