# CVE-2017-20178: Codiad process.php saveJSON information disclosure

> Remote attackers can exploit the saveJSON function in Codiad to disclose sensitive information, requiring high complexity and permissions.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2023
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-2q79-56rq-8v3c

## What is CVE-2017-20178?

CVE-2017-20178 is a low-severity vulnerability in Codiad, published on 21 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in Codiad 2.8.0. It has been rated as problematic. Affected by this issue is the function saveJSON of the file components/install/process.php. The manipulation of the argument data leads to information disclosure. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 2.8.1 is able to address this issue. The patch is identified as 517119de673e62547ee472a730be0604f44342b5. It is recommended to upgrade the affected component. VDB-221498 is the identifier assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-20178?

2 open source packages ship an affected version, including codiad/codiad. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codiad/codiad` | Packagist | All versions | 2.8.1 |
| `codiad/codiad` | Packagist | All versions | 2.8.1 |

Products: Codiad Codiad.

## How do I fix CVE-2017-20178?

Upgrade codiad/codiad to 2.8.1 or later.

## Is CVE-2017-20178 being exploited?

There is no known exploitation of CVE-2017-20178 in the wild and no public exploit code.

## Other vulnerabilities in Codiad

- [CVE-2019-19208](https://insights.sbomify.com/CVE-2019-19208/): Code injection in codiad (critical 9.8)
- [CVE-2018-14009](https://insights.sbomify.com/CVE-2018-14009/): Codiad remote code execution vulnerability (critical 9.8)
- [CVE-2017-11366](https://insights.sbomify.com/CVE-2017-11366/): Codiad Vulnerable to Shell Command Injection (critical 9.8)
- [CVE-2020-14043](https://insights.sbomify.com/CVE-2020-14043/): Codiad CSRF Vulnerability (high 8.8)
- [CVE-2020-23355](https://insights.sbomify.com/CVE-2020-23355/): Codiad Vulnerable to PHP Magic Hash Vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-20178 and fix it if it is affected.

What it is: CVE-2017-20178 is a low-severity vulnerability in Codiad, published on 21 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-20178 in the wild and no public exploit code.

Affected packages and fixed versions:
- codiad/codiad (Packagist): affected all versions; fixed in 2.8.1
- codiad/codiad (Packagist): affected all versions; fixed in 2.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-20178/ (Markdown: https://insights.sbomify.com/CVE-2017-20178/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-20178
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-20178
- OSV: https://osv.dev/vulnerability/CVE-2017-20178

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-20178/
Summaries are generated and may contain mistakes; the official description above is the record.
