CVE-2017-20181 hgzojer Vocable Trainer VocableTrainerProvider.java path traversal

Medium 5.3 Published Updated

A local attacker can exploit a path traversal vulnerability in Vocable Trainer to read or modify arbitrary files on the device.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2017-20181?

CVE-2017-20181 is a medium-severity path traversal vulnerability in hgzojer Vocable Trainer, published on 6 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability classified as critical was found in hgzojer Vocable Trainer up to 1.3.0 on Android. This vulnerability affects unknown code of the file src/at/hgz/vocabletrainer/VocableTrainerProvider.java. The manipulation leads to path traversal. Attacking locally is a requirement. Upgrading to version 1.3.1 is able to address this issue. The name of the patch is accf6838078f8eb105cfc7865aba5c705fb68426. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-222328.

Weakness: CWE-22

Which versions are affected by CVE-2017-20181?

It affects 1 product.

Products include Vocable Trainer Project Vocable Trainer.

How do I fix CVE-2017-20181?

No fix has been published for CVE-2017-20181 yet. Limit exposure of the affected software until one is available.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2017-20181 being exploited?

There is no known exploitation of CVE-2017-20181 in the wild and no public exploit code.

Sources

Also known as GHSA-pp5w-fm5c-rhc4.

Is CVE-2017-20181 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free