{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20181 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2017-20181 yet. Limit exposure of the affected software until one is available.","what":"CVE-2017-20181 is a medium-severity path traversal vulnerability in hgzojer Vocable Trainer, published on 6 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-20181 and fix it if it is affected.\n\nWhat it is: CVE-2017-20181 is a medium-severity path traversal vulnerability in hgzojer Vocable Trainer, published on 6 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-20181 in the wild and no public exploit code.\n\nAffected product: hgzojer Vocable Trainer. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20181/ (Markdown: https://insights.sbomify.com/CVE-2017-20181/index.md)","id":"CVE-2017-20181","markdown":"https://insights.sbomify.com/CVE-2017-20181/index.md","name":"CVE-2017-20181","record":{"aliases":["GHSA-pp5w-fm5c-rhc4"],"analysis":{"component_type":"mobile_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Android vocabulary app","requires_auth":"low_privilege","summary":"A local attacker can exploit a path traversal vulnerability in Vocable Trainer to read or modify arbitrary files on the device.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"vocable_trainer","vendor":"vocable_trainer_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A vulnerability classified as critical was found in hgzojer Vocable Trainer up to 1.3.0 on Android. This vulnerability affects unknown code of the file src/at/hgz/vocabletrainer/VocableTrainerProvider.java. The manipulation leads to path traversal. Attacking locally is a requirement. Upgrading to version 1.3.1 is able to address this issue. The name of the patch is accf6838078f8eb105cfc7865aba5c705fb68426. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-222328.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"hgzojer Vocable Trainer VocableTrainerProvider.java path traversal","id":"CVE-2017-20181","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2017"},"n_packages":0,"n_references":4,"next":{"headline":"Mobile Vikings Django AJAX Utilities Backslash pagination.js Pagination cross site scripting","id":"CVE-2017-20182"},"packages":[],"prev":{"headline":"Zerocoin libzerocoin Proof CoinSpend.cpp CoinSpend data authenticity","id":"CVE-2017-20180"},"products":["Vocable Trainer"],"published":"2023-03-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-05","vendors":["hgzojer"]},"summary":"A local attacker can exploit a path traversal vulnerability in Vocable Trainer to read or modify arbitrary files on the device.","url":"https://insights.sbomify.com/CVE-2017-20181/"}