# CVE-2017-20181: hgzojer Vocable Trainer VocableTrainerProvider.java path traversal

> A local attacker can exploit a path traversal vulnerability in Vocable Trainer to read or modify arbitrary files on the device.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Mar 2023
- **Updated:** 5 Mar 2025
- **Also known as:** GHSA-pp5w-fm5c-rhc4

## What is CVE-2017-20181?

CVE-2017-20181 is a medium-severity path traversal vulnerability in hgzojer Vocable Trainer, published on 6 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability classified as critical was found in hgzojer Vocable Trainer up to 1.3.0 on Android. This vulnerability affects unknown code of the file src/at/hgz/vocabletrainer/VocableTrainerProvider.java. The manipulation leads to path traversal. Attacking locally is a requirement. Upgrading to version 1.3.1 is able to address this issue. The name of the patch is accf6838078f8eb105cfc7865aba5c705fb68426. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-222328.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2017-20181?

It affects 1 product.


Products: Vocable Trainer Project Vocable Trainer.

## How do I fix CVE-2017-20181?

No fix has been published for CVE-2017-20181 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-20181 being exploited?

There is no known exploitation of CVE-2017-20181 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-20181 and fix it if it is affected.

What it is: CVE-2017-20181 is a medium-severity path traversal vulnerability in hgzojer Vocable Trainer, published on 6 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-20181 in the wild and no public exploit code.

Affected product: hgzojer Vocable Trainer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-20181/ (Markdown: https://insights.sbomify.com/CVE-2017-20181/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-20181
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-20181
- OSV: https://osv.dev/vulnerability/CVE-2017-20181

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-20181/
Summaries are generated and may contain mistakes; the official description above is the record.
