{"answers":{"affected":"3 open source packages ship an affected version, including django-ajax-utilities. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20182 in the wild and no public exploit code.","fix":"Upgrade django-ajax-utilities to 1.2.8 or later.","what":"CVE-2017-20182 is a low-severity cross-site scripting vulnerability in Mobile Vikings Django AJAX Utilities, published on 10 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-20182 and fix it if it is affected.\n\nWhat it is: CVE-2017-20182 is a low-severity cross-site scripting vulnerability in Mobile Vikings Django AJAX Utilities, published on 10 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-20182 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- django-ajax-utilities (PyPI): affected all versions; fixed in 1.2.8\n- django-ajax-utilities (PyPI): affected all versions; fixed in 1.2.8\n- django-ajax-utilities (PyPI): affected all versions; fixed in 1.2.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20182/ (Markdown: https://insights.sbomify.com/CVE-2017-20182/index.md)","id":"CVE-2017-20182","markdown":"https://insights.sbomify.com/CVE-2017-20182/index.md","name":"CVE-2017-20182","record":{"aliases":["GHSA-p4g9-c9qr-wmg5","PYSEC-2026-803"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Django AJAX Utilities","requires_auth":"low_privilege","summary":"Cross-site scripting vulnerability in Django AJAX Utilities allows remote attackers to inject malicious scripts via the pagination URL argument.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"django_ajax_utilities","vendor":"mobilevikings"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in Mobile Vikings Django AJAX Utilities up to 1.2.1 and classified as problematic. This issue affects the function Pagination of the file django_ajax/static/ajax-utilities/js/pagination.js of the component Backslash Handler. The manipulation of the argument url leads to cross site scripting. The attack may be initiated remotely. The patch is named 329eb1dd1580ca1f9d4f95bc69939833226515c9. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-222611.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mobile Vikings Django AJAX Utilities Backslash pagination.js Pagination cross site scripting","id":"CVE-2017-20182","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":3,"n_references":3,"next":{"headline":"External Media without Import Plugin external-media-without-import.php print_media_new_panel cross site scripting","id":"CVE-2017-20183"},"packages":[{"ecosystem":"PyPI","fixed":["1.2.8"],"introduced":["0"],"last_affected":[],"package":"django-ajax-utilities","purl":null,"source":"GHSA-p4g9-c9qr-wmg5"},{"ecosystem":"PyPI","fixed":["1.2.8"],"introduced":["0"],"last_affected":[],"package":"django-ajax-utilities","purl":"pkg:pypi/django-ajax-utilities","source":"GHSA-p4g9-c9qr-wmg5"},{"ecosystem":"PyPI","fixed":["1.2.8"],"introduced":["0"],"last_affected":[],"package":"django-ajax-utilities","purl":"pkg:pypi/django-ajax-utilities","source":"PYSEC-2026-803"}],"prev":{"headline":"hgzojer Vocable Trainer VocableTrainerProvider.java path traversal","id":"CVE-2017-20181"},"products":["Django AJAX Utilities"],"published":"2023-03-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-22","vendors":["Mobile Vikings"]},"summary":"Cross-site scripting vulnerability in Django AJAX Utilities allows remote attackers to inject malicious scripts via the pagination URL argument.","url":"https://insights.sbomify.com/CVE-2017-20182/"}