{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20183 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2017-20183 yet. Limit exposure of the affected software until one is available.","what":"CVE-2017-20183 is a low-severity cross-site scripting vulnerability in External Media without Import Plugin, published on 5 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-20183 and fix it if it is affected.\n\nWhat it is: CVE-2017-20183 is a low-severity cross-site scripting vulnerability in External Media without Import Plugin, published on 5 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-20183 in the wild and no public exploit code.\n\nAffected product: External Media without Import Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20183/ (Markdown: https://insights.sbomify.com/CVE-2017-20183/index.md)","id":"CVE-2017-20183","markdown":"https://insights.sbomify.com/CVE-2017-20183/index.md","name":"CVE-2017-20183","record":{"aliases":["GHSA-hqpv-5395-79p5"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts via media panel parameters in the External Media without Import WordPress plugin, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"external_media_without_import","vendor":"external_media_without_import_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in External Media without Import Plugin up to 1.0.0 on WordPress. It has been declared as problematic. This vulnerability affects the function print_media_new_panel of the file external-media-without-import.php. The manipulation of the argument url/error/width/height/mime-type leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.0.1 is able to address this issue. The patch is identified as 9d2ecd159a6e2e3f710b4f1c28e2714f66502746. It is recommended to upgrade the affected component. VDB-227950 is the identifier assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"External Media without Import Plugin external-media-without-import.php print_media_new_panel cross site scripting","id":"CVE-2017-20183","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2017"},"n_packages":0,"n_references":4,"next":{"headline":"Carlo Gavazzi Powersoft prone to Path Traversal","id":"CVE-2017-20184"},"packages":[],"prev":{"headline":"Mobile Vikings Django AJAX Utilities Backslash pagination.js Pagination cross site scripting","id":"CVE-2017-20182"},"products":["External Media without Import Plugin"],"published":"2023-05-05","related":[{"cvss_score":6.5,"headline":"External Media without Import \u003c= 1.1.2 - Subscriber+ Blind SSRF","id":"CVE-2022-1398","kev_date_added":null,"published":"2022-05-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can inject malicious scripts via media panel parameters in the External Media without Import WordPress plugin, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2017-20183/"}