{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20186 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2017-20186 yet. Limit exposure of the affected software until one is available.","what":"CVE-2017-20186 is a low-severity denial of service vulnerability in nikooo777 ckSurf, published on 28 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-20186 and fix it if it is affected.\n\nWhat it is: CVE-2017-20186 is a low-severity denial of service vulnerability in nikooo777 ckSurf, published on 28 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-20186 in the wild and no public exploit code.\n\nAffected product: nikooo777 ckSurf. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20186/ (Markdown: https://insights.sbomify.com/CVE-2017-20186/index.md)","id":"CVE-2017-20186","markdown":"https://insights.sbomify.com/CVE-2017-20186/index.md","name":"CVE-2017-20186","record":{"aliases":["GHSA-7hcf-mh7x-3c8q"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Counter-Strike plugin","requires_auth":"low_privilege","summary":"An attacker can cause a denial of service in the ckSurf plugin by manipulating the spectator list name argument.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"cksurf","vendor":"nikooo777"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-404","name":"Improper Resource Shutdown or Release"}],"description":"** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in nikooo777 ckSurf up to 1.19.2. It has been declared as problematic. This vulnerability affects the function SpecListMenuDead of the file csgo/addons/sourcemod/scripting/ckSurf/misc.sp of the component Spectator List Name Handler. The manipulation of the argument cleanName leads to denial of service. Upgrading to version 1.21.0 is able to address this issue. The name of the patch is fd6318d99083a06363091441a0614bd2f21068e6. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-238156. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"nikooo777 ckSurf Spectator List Name misc.sp SpecListMenuDead denial of service","id":"CVE-2017-20186","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":0,"n_references":5,"next":{"headline":"Magnesium-PHP Base.php formatEmailString injection","id":"CVE-2017-20187"},"packages":[],"prev":{"headline":"Fuzzy SWMP GET Parameter swmp.php cross site scripting","id":"CVE-2017-20185"},"products":["ckSurf"],"published":"2023-08-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-01","vendors":["nikooo777"]},"summary":"An attacker can cause a denial of service in the ckSurf plugin by manipulating the spectator list name argument.","url":"https://insights.sbomify.com/CVE-2017-20186/"}