# CVE-2017-20186: nikooo777 ckSurf Spectator List Name misc.sp SpecListMenuDead denial of service

> An attacker can cause a denial of service in the ckSurf plugin by manipulating the spectator list name argument.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Aug 2023
- **Updated:** 1 Jul 2025
- **Also known as:** GHSA-7hcf-mh7x-3c8q

## What is CVE-2017-20186?

CVE-2017-20186 is a low-severity denial of service vulnerability in nikooo777 ckSurf, published on 28 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in nikooo777 ckSurf up to 1.19.2. It has been declared as problematic. This vulnerability affects the function SpecListMenuDead of the file csgo/addons/sourcemod/scripting/ckSurf/misc.sp of the component Spectator List Name Handler. The manipulation of the argument cleanName leads to denial of service. Upgrading to version 1.21.0 is able to address this issue. The name of the patch is fd6318d99083a06363091441a0614bd2f21068e6. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-238156. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2017-20186?

It affects 1 product.


Products: Nikooo777 Cksurf.

## How do I fix CVE-2017-20186?

No fix has been published for CVE-2017-20186 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-20186 being exploited?

There is no known exploitation of CVE-2017-20186 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-20186 and fix it if it is affected.

What it is: CVE-2017-20186 is a low-severity denial of service vulnerability in nikooo777 ckSurf, published on 28 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-20186 in the wild and no public exploit code.

Affected product: nikooo777 ckSurf. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-20186/ (Markdown: https://insights.sbomify.com/CVE-2017-20186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-20186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-20186
- OSV: https://osv.dev/vulnerability/CVE-2017-20186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-20186/
Summaries are generated and may contain mistakes; the official description above is the record.
