CVE-2017-20187 Magnesium-PHP Base.php formatEmailString injection

Low 3.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2017-20187?

CVE-2017-20187 is a low-severity vulnerability in Magnesium-PHP, published on 5 Nov 2023.

Official description

** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in Magnesium-PHP up to 0.3.0. It has been classified as problematic. Affected is the function formatEmailString of the file src/Magnesium/Message/Base.php. The manipulation of the argument email/name leads to injection. Upgrading to version 0.3.1 is able to address this issue. The patch is identified as 500d340e1f6421007413cc08a8383475221c2604. It is recommended to upgrade the affected component. VDB-244482 is the identifier assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-74

Which versions are affected by CVE-2017-20187?

2 open source packages ship an affected version, including floriangaerber/magnesium. It affects 1 product.

PackageAffectedFixed in
floriangaerber/magnesium PackagistAll versions0.3.1
floriangaerber/magnesium PackagistAll versions0.3.1

Products include Floriangaerber Magnesium-Php.

How do I fix CVE-2017-20187?

Upgrade floriangaerber/magnesium to 0.3.1 or later.

Is CVE-2017-20187 being exploited?

There is no known exploitation of CVE-2017-20187 in the wild and no public exploit code.

Sources

Also known as GHSA-8pp6-5qpw-85g3.

Is CVE-2017-20187 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free