{"answers":{"affected":"2 open source packages ship an affected version, including floriangaerber/magnesium. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20187 in the wild and no public exploit code.","fix":"Upgrade floriangaerber/magnesium to 0.3.1 or later.","what":"CVE-2017-20187 is a low-severity vulnerability in Magnesium-PHP, published on 5 Nov 2023."},"fix_prompt":"Check this codebase for CVE-2017-20187 and fix it if it is affected.\n\nWhat it is: CVE-2017-20187 is a low-severity vulnerability in Magnesium-PHP, published on 5 Nov 2023. \nExploitation: There is no known exploitation of CVE-2017-20187 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- floriangaerber/magnesium (Packagist): affected all versions; fixed in 0.3.1\n- floriangaerber/magnesium (Packagist): affected all versions; fixed in 0.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20187/ (Markdown: https://insights.sbomify.com/CVE-2017-20187/index.md)","id":"CVE-2017-20187","markdown":"https://insights.sbomify.com/CVE-2017-20187/index.md","name":"CVE-2017-20187","record":{"aliases":["GHSA-8pp6-5qpw-85g3"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[{"product":"magnesium-php","vendor":"floriangaerber"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in Magnesium-PHP up to 0.3.0. It has been classified as problematic. Affected is the function formatEmailString of the file src/Magnesium/Message/Base.php. The manipulation of the argument email/name leads to injection. Upgrading to version 0.3.1 is able to address this issue. The patch is identified as 500d340e1f6421007413cc08a8383475221c2604. It is recommended to upgrade the affected component. VDB-244482 is the identifier assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Magnesium-PHP Base.php formatEmailString injection","id":"CVE-2017-20187","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":null,"year":"2017"},"n_packages":2,"n_references":4,"next":{"headline":"Zimbra zm-ajax XFormItem.js XFormItem.prototype.setError cross site scripting","id":"CVE-2017-20188"},"packages":[{"ecosystem":"Packagist","fixed":["0.3.1"],"introduced":["0"],"last_affected":[],"package":"floriangaerber/magnesium","purl":null,"source":"GHSA-8pp6-5qpw-85g3"},{"ecosystem":"Packagist","fixed":["0.3.1"],"introduced":["0"],"last_affected":[],"package":"floriangaerber/magnesium","purl":"pkg:composer/floriangaerber/magnesium","source":"GHSA-8pp6-5qpw-85g3"}],"prev":{"headline":"nikooo777 ckSurf Spectator List Name misc.sp SpecListMenuDead denial of service","id":"CVE-2017-20186"},"products":["Magnesium-PHP"],"published":"2023-11-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2017-20187/"}