# CVE-2017-20187: Magnesium-PHP Base.php formatEmailString injection


- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 Nov 2023
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-8pp6-5qpw-85g3

## What is CVE-2017-20187?

CVE-2017-20187 is a low-severity vulnerability in Magnesium-PHP, published on 5 Nov 2023. 

### Official description

** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in Magnesium-PHP up to 0.3.0. It has been classified as problematic. Affected is the function formatEmailString of the file src/Magnesium/Message/Base.php. The manipulation of the argument email/name leads to injection. Upgrading to version 0.3.1 is able to address this issue. The patch is identified as 500d340e1f6421007413cc08a8383475221c2604. It is recommended to upgrade the affected component. VDB-244482 is the identifier assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2017-20187?

2 open source packages ship an affected version, including floriangaerber/magnesium. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `floriangaerber/magnesium` | Packagist | All versions | 0.3.1 |
| `floriangaerber/magnesium` | Packagist | All versions | 0.3.1 |

Products: Floriangaerber Magnesium-Php.

## How do I fix CVE-2017-20187?

Upgrade floriangaerber/magnesium to 0.3.1 or later.

## Is CVE-2017-20187 being exploited?

There is no known exploitation of CVE-2017-20187 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-20187 and fix it if it is affected.

What it is: CVE-2017-20187 is a low-severity vulnerability in Magnesium-PHP, published on 5 Nov 2023. 
Exploitation: There is no known exploitation of CVE-2017-20187 in the wild and no public exploit code.

Affected packages and fixed versions:
- floriangaerber/magnesium (Packagist): affected all versions; fixed in 0.3.1
- floriangaerber/magnesium (Packagist): affected all versions; fixed in 0.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-20187/ (Markdown: https://insights.sbomify.com/CVE-2017-20187/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-20187
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-20187
- OSV: https://osv.dev/vulnerability/CVE-2017-20187

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-20187/
Summaries are generated and may contain mistakes; the official description above is the record.
