{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20188 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2017-20188 yet. Limit exposure of the affected software until one is available.","what":"CVE-2017-20188 is a low-severity cross-site scripting vulnerability in Zimbra zm-ajax, published on 2 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-20188 and fix it if it is affected.\n\nWhat it is: CVE-2017-20188 is a low-severity cross-site scripting vulnerability in Zimbra zm-ajax, published on 2 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-20188 in the wild and no public exploit code.\n\nAffected product: Zimbra zm-ajax. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20188/ (Markdown: https://insights.sbomify.com/CVE-2017-20188/index.md)","id":"CVE-2017-20188","markdown":"https://insights.sbomify.com/CVE-2017-20188/index.md","name":"CVE-2017-20188","record":{"aliases":["GHSA-47rp-456r-h3xf"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Zimbra Collaboration Suite","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts via the setError function in Zimbra zm-ajax, potentially compromising user accounts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"zm-ajax","vendor":"zimbra"}],"cvss":{"score":2.6,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability has been found in Zimbra zm-ajax up to 8.8.1 and classified as problematic. Affected by this vulnerability is the function XFormItem.prototype.setError of the file WebRoot/js/ajax/dwt/xforms/XFormItem.js. The manipulation of the argument message leads to cross site scripting. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 8.8.2 is able to address this issue. The identifier of the patch is 8d039d6efe80780adc40c6f670c06d21de272105. It is recommended to upgrade the affected component. The identifier VDB-249421 was assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Zimbra zm-ajax XFormItem.js XFormItem.prototype.setError cross site scripting","id":"CVE-2017-20188","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2017"},"n_packages":0,"n_references":4,"next":{"headline":"Clojure classes can be used to craft a serialized object that runs arbitrary code on deserialization","id":"CVE-2017-20189"},"packages":[],"prev":{"headline":"Magnesium-PHP Base.php formatEmailString injection","id":"CVE-2017-20187"},"products":["zm-ajax"],"published":"2024-01-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-03","vendors":["Zimbra"]},"summary":"Remote attackers can execute arbitrary scripts via the setError function in Zimbra zm-ajax, potentially compromising user accounts.","url":"https://insights.sbomify.com/CVE-2017-20188/"}