# CVE-2017-20189: Clojure classes can be used to craft a serialized object that runs arbitrary code on deserialization


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Jan 2024
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2017-20189, GHSA-jgxc-8mwq-9xqw, ROOT-APP-MAVEN-CVE-2017-20189, UBUNTU-CVE-2017-20189

## What is CVE-2017-20189?

CVE-2017-20189 is a critical vulnerability in n/a, published on 22 Jan 2024. 

### Official description

In Clojure before 1.9.0, classes can be used to construct a serialized object that executes arbitrary code upon deserialization. This is relevant if a server deserializes untrusted objects.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2017-20189?

2 open source packages ship an affected version, including org.clojure:clojure. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.clojure:clojure` | Maven | All versions | 1.9.0 |
| `org.clojure:clojure` | Maven | All versions | 1.9.0 |

Products: Clojure Clojure.

## How do I fix CVE-2017-20189?

Upgrade org.clojure:clojure to 1.9.0 or later.

## Is CVE-2017-20189 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-20189 exists.

## Other vulnerabilities in n/a

- [CVE-2024-22871](https://insights.sbomify.com/CVE-2024-22871/): Reading specially crafted serializable objects from an untrusted source may cause an infinite loop and denial of service (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-20189 and fix it if it is affected.

What it is: CVE-2017-20189 is a critical vulnerability in n/a, published on 22 Jan 2024. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-20189 exists.

Affected packages and fixed versions:
- org.clojure:clojure (Maven): affected all versions; fixed in 1.9.0
- org.clojure:clojure (Maven): affected all versions; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-20189/ (Markdown: https://insights.sbomify.com/CVE-2017-20189/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-20189
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-20189
- OSV: https://osv.dev/vulnerability/CVE-2017-20189

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-20189/
Summaries are generated and may contain mistakes; the official description above is the record.
