CVE-2017-20191 Zimbra zm-admin-ajax Form Textbox Field Error XFormItem.js XFormItem.prototype.setError cross site scripting

Low 3.5 Published Updated

Remote attackers can execute arbitrary scripts via the admin AJAX form error handler, potentially compromising user accounts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2017-20191?

CVE-2017-20191 is a low-severity cross-site scripting vulnerability in Zimbra zm-admin-ajax, published on 31 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in Zimbra zm-admin-ajax up to 8.8.1. It has been classified as problematic. This affects the function XFormItem.prototype.setError of the file WebRoot/js/ajax/dwt/xforms/XFormItem.js of the component Form Textbox Field Error Handler. The manipulation of the argument message leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 8.8.2 is able to address this issue. The identifier of the patch is bb240ce0c71c01caabaa43eed30c78ba8d7d3591. It is recommended to upgrade the affected component. The identifier VDB-258621 was assigned to this vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2017-20191?

How do I fix CVE-2017-20191?

No fix has been published for CVE-2017-20191 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-20191 being exploited?

There is no known exploitation of CVE-2017-20191 in the wild and no public exploit code.

Sources

Also known as GHSA-pg5r-9j5r-4vcp.

Is CVE-2017-20191 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free