# CVE-2017-20191: Zimbra zm-admin-ajax Form Textbox Field Error XFormItem.js XFormItem.prototype.setError cross site scripting

> Remote attackers can execute arbitrary scripts via the admin AJAX form error handler, potentially compromising user accounts.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 31 Mar 2024
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-pg5r-9j5r-4vcp

## What is CVE-2017-20191?

CVE-2017-20191 is a low-severity cross-site scripting vulnerability in Zimbra zm-admin-ajax, published on 31 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in Zimbra zm-admin-ajax up to 8.8.1. It has been classified as problematic. This affects the function XFormItem.prototype.setError of the file WebRoot/js/ajax/dwt/xforms/XFormItem.js of the component Form Textbox Field Error Handler. The manipulation of the argument message leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 8.8.2 is able to address this issue. The identifier of the patch is bb240ce0c71c01caabaa43eed30c78ba8d7d3591. It is recommended to upgrade the affected component. The identifier VDB-258621 was assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-20191?


## How do I fix CVE-2017-20191?

No fix has been published for CVE-2017-20191 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-20191 being exploited?

There is no known exploitation of CVE-2017-20191 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-20191 and fix it if it is affected.

What it is: CVE-2017-20191 is a low-severity cross-site scripting vulnerability in Zimbra zm-admin-ajax, published on 31 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-20191 in the wild and no public exploit code.

Affected product: Zimbra zm-admin-ajax. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-20191/ (Markdown: https://insights.sbomify.com/CVE-2017-20191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-20191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-20191
- OSV: https://osv.dev/vulnerability/CVE-2017-20191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-20191/
Summaries are generated and may contain mistakes; the official description above is the record.
