# CVE-2017-20199: Buttercup buttercup-browser-extension Vault access control

> Attacker can bypass access controls to read or modify vault data in the Buttercup browser extension.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Aug 2025
- **Updated:** 27 Aug 2025
- **Also known as:** GHSA-639h-gpc4-26xv

## What is CVE-2017-20199?

CVE-2017-20199 is a low-severity missing authorization vulnerability in buttercup-browser-extension, published on 15 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in Buttercup buttercup-browser-extension up to 0.14.2. Affected by this vulnerability is an unknown functionality of the component Vault Handler. The manipulation results in improper access controls. The attack may be performed from a remote location. A high complexity level is associated with this attack. The exploitation appears to be difficult. The exploit has been made public and could be used. Upgrading to version 1.0.1 addresses this issue. The patch is identified as 89. Upgrading the affected component is recommended. This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-284 (Improper Access Control), CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2017-20199?

It affects 1 product.


Products: Buttercup Buttercup.

## How do I fix CVE-2017-20199?

No fix has been published for CVE-2017-20199 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-20199 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-20199 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-20199 and fix it if it is affected.

What it is: CVE-2017-20199 is a low-severity missing authorization vulnerability in buttercup-browser-extension, published on 15 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-20199 exists.

Affected product: buttercup-browser-extension. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-20199/ (Markdown: https://insights.sbomify.com/CVE-2017-20199/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-20199
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-20199
- OSV: https://osv.dev/vulnerability/CVE-2017-20199

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-20199/
Summaries are generated and may contain mistakes; the official description above is the record.
