{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-20230 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-20230 is a critical memory corruption vulnerability in NWCLARK Storable, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-20230 and fix it if it is affected.\n\nWhat it is: CVE-2017-20230 is a critical memory corruption vulnerability in NWCLARK Storable, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-20230 in the wild and no public exploit code.\n\nAffected product: NWCLARK Storable. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-20230/ (Markdown: https://insights.sbomify.com/CVE-2017-20230/index.md)","id":"CVE-2017-20230","markdown":"https://insights.sbomify.com/CVE-2017-20230/index.md","name":"CVE-2017-20230","record":{"aliases":["DEBIAN-CVE-2017-20230","GHSA-6r7m-2wh8-438w","RHSA-2026:7578","SUSE-SU-2026:1567-1","UBUNTU-CVE-2017-20230"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Perl Storable library","requires_auth":"none","summary":"A stack overflow in the Perl Storable library allows attackers to cause denial of service or potentially execute code via crafted data.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CPANSec","cpe":[{"product":"storable","vendor":"nwclark"}],"cvss":{"score":10,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-121","name":"Stack-based Buffer Overflow"}],"description":"Storable versions before 3.05 for Perl has a stack overflow.\n\nThe retrieve_hook function stored the length of the class name into a signed integer but in read operations treated the length as unsigned. This allowed an attacker to craft data that could trigger the overflow.","ecosystems":["Red Hat:hummingbird:1","SUSE:Linux Enterprise Server 12 SP5-LTSS","SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Storable versions before 3.05 for Perl has a stack overflow","id":"CVE-2017-20230","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2017"},"n_packages":4,"n_references":5,"next":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority.","id":"CVE-2017-20232"},"packages":[{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:3.37-522.1.hum1"],"introduced":["0"],"last_affected":[],"package":"perl-Storable","purl":"pkg:rpm/redhat/perl-Storable","source":"RHSA-2026:7578"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:3.37-522.1.hum1"],"introduced":["0"],"last_affected":[],"package":"perl-Storable-tests","purl":"pkg:rpm/redhat/perl-Storable-tests","source":"RHSA-2026:7578"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5-LTSS","fixed":["5.18.2-12.32.1"],"introduced":["0"],"last_affected":[],"package":"perl","purl":"pkg:rpm/suse/perl\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5-LTSS","source":"SUSE-SU-2026:1567-1"},{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["5.18.2-12.32.1"],"introduced":["0"],"last_affected":[],"package":"perl","purl":"pkg:rpm/suse/perl\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2026:1567-1"}],"prev":{"headline":"MAWK 1.3.3-17 Stack-Based Buffer Overflow","id":"CVE-2017-20229"},"products":["Storable"],"published":"2026-04-21","related":[{"cvss_score":9.8,"headline":"Storable versions before 3.41 for Perl have a signed integer overflow when deserializing a crafted SX_HOOK record","id":"CVE-2026-57433","kev_date_added":null,"published":"2026-07-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-21","vendors":["NWCLARK"]},"summary":"A stack overflow in the Perl Storable library allows attackers to cause denial of service or potentially execute code via crafted data.","url":"https://insights.sbomify.com/CVE-2017-20230/"}