{"answers":{"affected":"4 open source packages ship an affected version, including smalruby-editor and smalruby. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-2096 in the wild and no public exploit code.","fix":"Upgrade smalruby-editor to 0.4.1 or later.","what":"CVE-2017-2096 is a critical command injection vulnerability in smalruby-editor, published on 28 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-2096 and fix it if it is affected.\n\nWhat it is: CVE-2017-2096 is a critical command injection vulnerability in smalruby-editor, published on 28 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-2096 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- smalruby-editor (RubyGems): affected all versions; fixed in 0.4.1\n- smalruby-editor (RubyGems): affected all versions; fixed in 0.4.1\n- smalruby (RubyGems): affected all versions; fixed in 0.1.11\n- smalruby (RubyGems): affected all versions; fixed in 0.1.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-2096/ (Markdown: https://insights.sbomify.com/CVE-2017-2096/index.md)","id":"CVE-2017-2096","markdown":"https://insights.sbomify.com/CVE-2017-2096/index.md","name":"CVE-2017-2096","record":{"aliases":["GHSA-f489-655r-x6gr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby educational editor","requires_auth":"none","summary":"Remote attackers can execute arbitrary OS commands in smalruby-editor, requiring an upgrade to secure the application.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"smalruby-editor","vendor":"smalruby"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"smalruby and smalruby-editor vulnerable to OS Command Injection","id":"CVE-2017-2096","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2017"},"n_packages":4,"n_references":3,"next":{"headline":"Cross-site request forgery in Knowledge","id":"CVE-2017-2097"},"packages":[{"ecosystem":"RubyGems","fixed":["0.1.11"],"introduced":["0"],"last_affected":[],"package":"smalruby","purl":null,"source":"GHSA-f489-655r-x6gr"},{"ecosystem":"RubyGems","fixed":["0.1.11"],"introduced":["0"],"last_affected":[],"package":"smalruby","purl":"pkg:gem/smalruby","source":"GHSA-f489-655r-x6gr"},{"ecosystem":"RubyGems","fixed":["0.4.1"],"introduced":["0"],"last_affected":[],"package":"smalruby-editor","purl":null,"source":"GHSA-f489-655r-x6gr"},{"ecosystem":"RubyGems","fixed":["0.4.1"],"introduced":["0"],"last_affected":[],"package":"smalruby-editor","purl":"pkg:gem/smalruby-editor","source":"GHSA-f489-655r-x6gr"}],"prev":{"headline":"Missing authorization in Cybozu Garoon","id":"CVE-2017-2095"},"products":["smalruby-editor"],"published":"2017-04-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Ruby Programming Shounendan"]},"summary":"Remote attackers can execute arbitrary OS commands in smalruby-editor, requiring an upgrade to secure the application.","url":"https://insights.sbomify.com/CVE-2017-2096/"}