# CVE-2017-2096: smalruby and smalruby-editor vulnerable to OS Command Injection

> Remote attackers can execute arbitrary OS commands in smalruby-editor, requiring an upgrade to secure the application.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Apr 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-f489-655r-x6gr

## What is CVE-2017-2096?

CVE-2017-2096 is a critical command injection vulnerability in smalruby-editor, published on 28 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2017-2096?

4 open source packages ship an affected version, including smalruby-editor and smalruby. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `smalruby-editor` | RubyGems | All versions | 0.4.1 |
| `smalruby-editor` | RubyGems | All versions | 0.4.1 |
| `smalruby` | RubyGems | All versions | 0.1.11 |
| `smalruby` | RubyGems | All versions | 0.1.11 |

Products: Smalruby Smalruby-Editor.

## How do I fix CVE-2017-2096?

Upgrade smalruby-editor to 0.4.1 or later.

## Is CVE-2017-2096 being exploited?

There is no known exploitation of CVE-2017-2096 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2096 and fix it if it is affected.

What it is: CVE-2017-2096 is a critical command injection vulnerability in smalruby-editor, published on 28 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-2096 in the wild and no public exploit code.

Affected packages and fixed versions:
- smalruby-editor (RubyGems): affected all versions; fixed in 0.4.1
- smalruby-editor (RubyGems): affected all versions; fixed in 0.4.1
- smalruby (RubyGems): affected all versions; fixed in 0.1.11
- smalruby (RubyGems): affected all versions; fixed in 0.1.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2096/ (Markdown: https://insights.sbomify.com/CVE-2017-2096/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2096
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2096
- OSV: https://osv.dev/vulnerability/CVE-2017-2096

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2096/
Summaries are generated and may contain mistakes; the official description above is the record.
