# CVE-2017-2171: Cross-site scripting in Captcha

> Remote attackers can inject arbitrary web script via multiple BestWebSoft WordPress plugins, potentially compromising user sessions and site integrity.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 22 May 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-947h-g3wj-rr28

## What is CVE-2017-2171?

CVE-2017-2171 is a medium-severity cross-site scripting vulnerability in BestWebSoft Captcha, published on 22 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting vulnerability in Captcha prior to version 4.3.0, Car Rental prior to version 1.0.5, Contact Form Multi prior to version 1.2.1, Contact Form prior to version 4.0.6, Contact Form to DB prior to version 1.5.7, Custom Admin Page prior to version 0.1.2, Custom Fields Search prior to version 1.3.2, Custom Search prior to version 1.36, Donate prior to version 2.1.1, Email Queue prior to version 1.1.2, Error Log Viewer prior to version 1.0.6, Facebook Button prior to version 2.54, Featured Posts prior to version 1.0.1, Gallery Categories prior to version 1.0.9, Gallery prior to version 4.5.0, Google +1 prior to version 1.3.4, Google AdSense prior to version 1.44, Google Analytics prior to version 1.7.1, Google Captcha (reCAPTCHA) prior to version 1.28, Google Maps prior to version 1.3.6, Google Shortlink prior to version 1.5.3, Google Sitemap prior to version 3.0.8, Htaccess prior to version 1.7.6, Job Board prior to version 1.1.3, Latest Posts prior to version 0.3, Limit Attempts prior to version 1.1.8, LinkedIn prior to version 1.0.5, Multilanguage prior to version 1.2.2, PDF & Print prior to version 1.9.4, Pagination prior to version 1.0.7, Pinterest prior to version 1.0.5, Popular Posts prior to version 1.0.5, Portfolio prior to version 2.4, Post to CSV prior to version 1.3.1, Profile Extra prior to version 1.0.7. PromoBar prior to version 1.1.1, Quotes and Tips prior to version 1.32, Re-attacher prior to version 1.0.9, Realty prior to version 1.1.0, Relevant - Related Posts prior to version 1.2.0, Sender prior to version 1.2.1, SMTP prior to version 1.1.0, Social Buttons Pack prior to version 1.1.1, Subscriber prior to version 1.3.5, Testimonials prior to version 0.1.9, Timesheet prior to version 0.1.5, Twitter Button prior to version 2.55, User Role prior to version 1.5.6, Updater prior to version 1.35, Visitors Online prior to version 1.0.0, and Zendesk Help Center prior to version 1.0.5 allows remote attackers to inject arbitrary web script or HTML via the function to display the BestWebSoft menu.

Weakness: CWE-91 (XML Injection), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-2171?

It affects 51 products.


Products: Bestwebsoft Captcha, Bestwebsoft Car Rental, Bestwebsoft Contact Form, Bestwebsoft Contact Form Multi, Bestwebsoft Contact Form to Db, Bestwebsoft Custom Admin Page, Bestwebsoft Custom Fields Search, Bestwebsoft Custom Search, Bestwebsoft Donate, Bestwebsoft Email Queue, Bestwebsoft Error Log Viewer, Bestwebsoft Facebook Button, Bestwebsoft Featured Posts, Bestwebsoft Gallery, Bestwebsoft Gallery Categories, Bestwebsoft Google \+1, Bestwebsoft Google Adsense, Bestwebsoft Google Analytics, Bestwebsoft Google Captcha \(Recaptcha\), Bestwebsoft Google Maps and 31 more.

## How do I fix CVE-2017-2171?

No fix has been published for CVE-2017-2171 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-2171 being exploited?

There is no known exploitation of CVE-2017-2171 in the wild and no public exploit code.

## Other vulnerabilities in BestWebSoft Captcha

- [CVE-2023-45771](https://insights.sbomify.com/CVE-2023-45771/): WordPress Contact Form With Captcha plugin <= 1.6.8 - Reflected Cross Site Scripting (XSS) vulnerability (high 7.1)
- [CVE-2014-9283](https://insights.sbomify.com/CVE-2014-9283/): Security feature bypass in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2171 and fix it if it is affected.

What it is: CVE-2017-2171 is a medium-severity cross-site scripting vulnerability in BestWebSoft Captcha, published on 22 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-2171 in the wild and no public exploit code.

Affected product: BestWebSoft Captcha. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2171/ (Markdown: https://insights.sbomify.com/CVE-2017-2171/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2171
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2171
- OSV: https://osv.dev/vulnerability/CVE-2017-2171

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2171/
Summaries are generated and may contain mistakes; the official description above is the record.
