{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-2295 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-2295 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 5 Jul 2017. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-2295 and fix it if it is affected.\n\nWhat it is: CVE-2017-2295 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 5 Jul 2017. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-2295 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-2295/ (Markdown: https://insights.sbomify.com/CVE-2017-2295/index.md)","id":"CVE-2017-2295","markdown":"https://insights.sbomify.com/CVE-2017-2295/index.md","name":"CVE-2017-2295","record":{"aliases":["DEBIAN-CVE-2017-2295","DLA-1012-1","DSA-3862-1","GHSA-988w-9qqw-43hr","MGASA-2017-0156","SUSE-SU-2017:2113-1","SUSE-SU-2018:0600-1","UBUNTU-CVE-2017-2295"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Puppet server","requires_auth":"low_privilege","summary":"An attacker can achieve remote code execution on the Puppet server by sending maliciously crafted data that triggers unsafe YAML deserialization.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"puppet","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"puppet","vendor":"puppet"}],"cvss":{"score":8.2,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Versions of Puppet prior to 4.10.1 will deserialize data off the wire (from the agent to the server, in this case) with a attacker-specified format. This could be used to force YAML deserialization in an unsafe manner, which would lead to remote code execution. This change constrains the format of data on the wire to PSON or safely decoded YAML.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP2","SUSE:Linux Enterprise Desktop 12 SP3","SUSE:Linux Enterprise Module for Advanced Systems Management 12","SUSE:Linux Enterprise Server 11 SP4","SUSE:Linux Enterprise Server for SAP Applications 11 SP4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Deserialization in Puppet server","id":"CVE-2017-2295","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"deserialization","year":"2017"},"n_packages":5,"n_references":3,"next":{"headline":"Denial of service in Puppet Enterprise","id":"CVE-2017-2296"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP2","fixed":["3.8.5-15.3.3"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":"pkg:rpm/suse/puppet\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP2","source":"SUSE-SU-2017:2113-1"},{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP3","fixed":["3.8.5-15.3.3"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":"pkg:rpm/suse/puppet\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP3","source":"SUSE-SU-2017:2113-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Advanced Systems Management 12","fixed":["3.8.5-15.3.3"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":"pkg:rpm/suse/puppet\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Advanced%20Systems%20Management%2012","source":"SUSE-SU-2017:2113-1"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4","fixed":["2.7.26-0.5.3.1"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":"pkg:rpm/suse/puppet\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4","source":"SUSE-SU-2018:0600-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 11 SP4","fixed":["2.7.26-0.5.3.1"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":"pkg:rpm/suse/puppet\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2011%20SP4","source":"SUSE-SU-2018:0600-1"}],"prev":{"headline":"Information disclosure in Puppet Enterprise","id":"CVE-2017-2294"},"products":["Puppet server"],"published":"2017-07-05","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Puppet"]},"summary":"An attacker can achieve remote code execution on the Puppet server by sending maliciously crafted data that triggers unsafe YAML deserialization.","url":"https://insights.sbomify.com/CVE-2017-2295/"}